summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2014-08-30 23:15:04 -0700
committerJohn MacFarlane <jgm@berkeley.edu>2014-08-30 23:15:04 -0700
commit44559055506461d2c675f978182aa20ee689433e (patch)
treea455dfcddd16c902023a34f8ae0f247171673298
parent374bb3c14785b77771d96319301ed5aef31089c5 (diff)
Makefile: simplified 'make dist'.
Note that this may not work with older cabal versions.
-rw-r--r--Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index 306a9c84e..589130b72 100644
--- a/Makefile
+++ b/Makefile
@@ -32,11 +32,8 @@ install: full
cabal copy
cabal register
-sdist: man
- # note: cabal sdist doesn't work well with preprocessors for some cabal versions
- ${setup} sdist
-
-dist: sdist
+dist: man
+ cabal sdist
rm -rf "pandoc-${version}"
tar xvzf dist/pandoc-${version}.tar.gz
cd pandoc-${version}
@@ -57,4 +54,4 @@ clean:
cabal clean
-rm ${MANPAGES}
-.PHONY: deps quick full install man clean test bench haddock sdist osxpkg dist prof
+.PHONY: deps quick full install man clean test bench haddock osxpkg dist prof