summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-07-03 04:11:57 +0000
committerfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-07-03 04:11:57 +0000
commitcd08eabd269a99c23aefb0fc71b00ec878b2af1a (patch)
treeb22f5cfcaeb6658b484c79abbab2c3f1bfbde57e
parentcc67d17dda9faae9102e54104292c8f88921e1c1 (diff)
Changes to website:
- Added groff man to list of output formats in index.txt - Added a demo of man page creation to demos page git-svn-id: https://pandoc.googlecode.com/svn/trunk@617 788f1e2b-df1e-0410-8736-df70ead52e1b
-rw-r--r--Makefile1
-rw-r--r--web/demos10
-rw-r--r--web/index.txt5
3 files changed, 11 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 13829b162..0e3ae2226 100644
--- a/Makefile
+++ b/Makefile
@@ -377,6 +377,7 @@ website: $(MAIN) html
$(web_dest)/changelog.txt; \
cp README $(web_dest)/ ; \
cp INSTALL $(web_dest)/ ; \
+ cp $(MANDIR)/man1/pandoc.1.md $(web_dest)/ ; \
sed -e 's/@TARBALL_NAME@/$(tarball_name)/g' $(web_src)/index.txt | \
sed -e 's/@OSX_DMG_NAME@/$(osx_dmg_name)/g' | \
sed -e 's/@WINDOWS_PKG_NAME@/$(win_pkg_name)/g' | \
diff --git a/web/demos b/web/demos
index 72455844b..a55a08da2 100644
--- a/web/demos
+++ b/web/demos
@@ -47,15 +47,19 @@ click on the name of the output file:
@ docbook2odf --input-file example9.db --output-file example11.odf
-12. Converting a web page to markdown:
+12. Man page:
+
+@ pandoc -s -w man pandoc.1.md -o pandoc.1
+
+13. Converting a web page to markdown:
@ html2markdown http://www.gnu.org/software/make/ -o example12.text
-13. From markdown to PDF:
+14. From markdown to PDF:
@ markdown2pdf README -o example13.pdf
-14. PDF with numbered sections and a custom LaTeX header:
+15. PDF with numbered sections and a custom LaTeX header:
@ markdown2pdf -N -C myheader.tex README -o example14.pdf
diff --git a/web/index.txt b/web/index.txt
index 3906642ce..c49924b52 100644
--- a/web/index.txt
+++ b/web/index.txt
@@ -4,8 +4,8 @@ Pandoc is a [Haskell] library for converting from one markup format
to another, and a command-line tool that uses this library. It can read
[markdown] and (subsets of) [reStructuredText], [HTML], and [LaTeX],
and it can write [markdown], [reStructuredText], [HTML], [LaTeX], [RTF],
-[DocBook XML], and [S5] HTML slide shows. Pandoc's version of markdown
-contains some enhancements, like footnotes and embedded LaTeX.
+[DocBook XML], [groff man], and [S5] HTML slide shows. Pandoc's version
+of markdown contains some enhancements, like footnotes and embedded LaTeX.
In contrast to existing tools for converting markdown to HTML, which
use regex substitutions, Pandoc has a modular design: it consists of a
@@ -84,6 +84,7 @@ kind.
[LaTeX]: http://www.latex-project.org/
[RTF]: http://en.wikipedia.org/wiki/Rich_Text_Format
[DocBook XML]: http://www.docbook.org/
+[groff man]: http://developer.apple.com/DOCUMENTATION/Darwin/Reference/ManPages/man7/groff_man.7.html
[Haskell]: http://www.haskell.org/
[GHC]: http://www.haskell.org/ghc/
[GPL]: http://www.gnu.org/copyleft/gpl.html