summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2017-11-20 21:34:22 -0800
committerJohn MacFarlane <jgm@berkeley.edu>2017-11-20 21:34:22 -0800
commit0eb132c51877bd7cc80699134ecfc7ddd2c44f8a (patch)
treeb8f1c879db2e2b2e2dbc64bbe2a01efec2eae31b /Makefile
parent63df9e3172e59986f452cd1c57a2344abb8fd2b2 (diff)
Makefile - create windows binary package as zip as well as msi.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 49689365e..a9d42e6af 100644
--- a/Makefile
+++ b/Makefile
@@ -47,7 +47,17 @@ debpkg: man/pandoc.1
macospkg: man/pandoc.1
./macos/make_macos_package.sh
-winpkg: pandoc-$(version)-windows.msi
+winpkg: pandoc-$(version)-windows.msi pandoc-$(version)-windows.zip
+
+pandoc-$(version)-windows.zip: pandoc-$(version)-windows.msi
+ -rm -rf wintmp && \
+ msiextract -C wintmp $< && \
+ cd wintmp/"Program Files" && \
+ mv Pandoc pandoc-$(version) && \
+ zip -r $@ pandoc-$(version) && \
+ mv $@ ../../ && \
+ cd ../.. && \
+ rm -rf wintmp
pandoc-$(version)-windows.msi:
wget 'https://ci.appveyor.com/api/projects/jgm/pandoc/artifacts/windows/pandoc-windows-i386.msi?branch=$(BRANCH)' -O pandoc.msi && \