summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2017-03-15 17:22:07 +0100
committerJohn MacFarlane <jgm@berkeley.edu>2017-03-15 17:22:07 +0100
commit257d96f199c1521cde0ee7147996e8c6e78a306c (patch)
treef827cff677f5a2da835a625ee8ee9f3a2c7babe2 /Makefile
parent482e5b78a05a02df512a495a2a67657879a2d436 (diff)
Makefile: allow make test to take TESTARGS.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 768d62169..77b6d85c0 100644
--- a/Makefile
+++ b/Makefile
@@ -10,8 +10,10 @@ full:
stack install --flag 'pandoc:embed_data_files' --test --test-arguments='-j4' --pedantic
stack haddock
+# Note: to accept current results of golden tests,
+# make test TESTARGS='--accept'
test:
- stack test --flag 'pandoc:embed_data_files' --fast --test-arguments='-j4 --hide-successes'
+ stack test --flag 'pandoc:embed_data_files' --fast --test-arguments='-j4 --hide-successes $(TESTARGS)'
bench:
stack bench