summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJohn MacFarlane <fiddlosopher@gmail.com>2015-03-28 15:37:02 -0700
committerJohn MacFarlane <fiddlosopher@gmail.com>2015-03-28 15:40:50 -0700
commit3f20fb3f9f8ccb2e6476e116e196b7e70ac559bb (patch)
tree6e639b274ab0e33d19d157b015ec197bc93f95ae /Makefile
parent524d284b88cc61a9cd958e2679effd1d0a01e1ac (diff)
Always build man pages. Removed make-pandoc-man-pages flag.
Updated INSTALL instructions. Makefile: removed man target, now that we generate man pages by default.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 0 insertions, 8 deletions
diff --git a/Makefile b/Makefile
index b30ec7eea..ce7d0a6ad 100644
--- a/Makefile
+++ b/Makefile
@@ -1,10 +1,5 @@
version=$(shell grep '^Version:' pandoc.cabal | awk '{print $$2;}')
-makemanpages=$(shell find dist -type f -name make-pandoc-man-pages)
-ifeq "${makemanpages}" ""
- makemanpages=@echo "You need to 'cabal configure -fmake-pandoc-man-pages && cabal build'" && exit 1
-endif
setup=dist/setup/setup
-MANPAGES=man/man1/pandoc.1 man/man5/pandoc_markdown.5
PREFIX ?= /usr/local
quick:
@@ -43,8 +38,6 @@ dist: man
debpkg:
./make_deb.sh
-man: $(MANPAGES)
-
osxpkg:
./make_osx_package.sh
@@ -56,7 +49,6 @@ osxpkg:
clean:
cabal clean
- -rm $(MANPAGES)
-rm -rf $(BINDIST) $(BINDIST).tar.gz
.PHONY: deps quick full install man clean test bench haddock osxpkg dist bindist prof