summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2017-08-09 13:21:18 -0700
committerJohn MacFarlane <jgm@berkeley.edu>2017-08-09 13:21:18 -0700
commit4cef2a296f6554387efdd638f441d3f150da22fa (patch)
tree466fbd0c30bd7bfca3e2fae940eb48b5ae61ea9d /Makefile
parentb4f069c11cd4491d2d032d7f51984e0b019a01c9 (diff)
Makefile: use nightly + colored output for quick.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index dd390a9c0..871020a17 100644
--- a/Makefile
+++ b/Makefile
@@ -4,7 +4,7 @@ sourcefiles=$(shell find pandoc.hs src test -name '*.hs')
BRANCH?=master
quick:
- stack install --resolver=nightly-2017-08-09 --install-ghc --flag 'pandoc:embed_data_files' --fast --test --test-arguments='-j4 --hide-successes $(TESTARGS)'
+ stack install --resolver=nightly-2017-08-09 --ghc-options='-fdiagnostics-color=always' --install-ghc --flag 'pandoc:embed_data_files' --fast --test --test-arguments='-j4 --hide-successes $(TESTARGS)'
full:
stack install --flag 'pandoc:embed_data_files' --flag 'pandoc:weigh-pandoc' --flag 'pandoc:trypandoc' --bench --no-run-benchmarks --test --test-arguments='-j4 --hide-successes' --ghc-options '-Wall -Werror -fno-warn-unused-do-bind -O0 -j4'