summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2018-01-18 08:42:43 -0800
committerJohn MacFarlane <jgm@berkeley.edu>2018-01-18 08:42:43 -0800
commit70ea1d19ea4aebf7a21dbe88a913c89aa22d752a (patch)
tree20e5d1964d43a79d3f12c15b01826a38145c9843 /Makefile
parent767a11c92b4681084f088ec05b72374295725fdf (diff)
Makefile - add prerelease sanity check for tabs in docs.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 7c6233db1..da6eabbe2 100644
--- a/Makefile
+++ b/Makefile
@@ -42,7 +42,10 @@ dist: man/pandoc.1
cd pandoc-${version}
stack setup && stack test && cd .. && rm -rf "pandoc-${version}"
-packages: winpkg debpkg macospkg
+packages: checkdocs sanitycheck winpkg debpkg macospkg
+
+checkdocs: README.md
+ ! grep -n -e "\t" MANUAL.txt changelog
debpkg: man/pandoc.1
make -C linux && \
@@ -109,4 +112,4 @@ update-website:
clean:
stack clean
-.PHONY: deps quick full haddock install clean test bench changes_github macospkg dist prof download_stats reformat lint weigh doc/lua-filters.md packages pandoc-templates trypandoc update-website
+.PHONY: deps quick full haddock install clean test bench changes_github macospkg dist prof download_stats reformat lint weigh doc/lua-filters.md packages pandoc-templates trypandoc update-website debpkg macospkg winpkg checkdocs