summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2016-07-14 10:29:46 -0700
committerJohn MacFarlane <jgm@berkeley.edu>2016-07-14 10:29:46 -0700
commit7826cc2a206ac0f33d83c5a1a14b3d44ea8e1117 (patch)
tree8a9870158f307402518b5fd97784a343bd0cd8de /Makefile
parentbbd7b533ae2f35c6024870c5849b76ceced3ea83 (diff)
Added winpkg target to Makefile.
This downloads the windows package from appveyor and signs it using the key. This way we needn't mess with a Windows VM to build the package.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 9620cf386..00eb51321 100644
--- a/Makefile
+++ b/Makefile
@@ -49,6 +49,13 @@ debpkg: man/pandoc.1
osxpkg: man/pandoc.1
./make_osx_package.sh
+winpkg: pandoc-$(version)-windows.msi
+
+pandoc-$(version)-windows.msi:
+ wget 'https://ci.appveyor.com/api/projects/jgm/pandoc/artifacts/windows/pandoc.msi?branch=master' -O pandoc.msi && \
+ osslsigncode sign -pkcs12 ~/Private/ComodoCodeSigning.exp2017.p12 -in pandoc.msi -i http://johnmacfarlane.net/ -t http://timestamp.comodoca.com/ -out $@ -askpass
+ rm pandoc.msi
+
man/pandoc.1: README man/pandoc.1.template
pandoc $< -t man -s --template man/pandoc.1.template \
--filter man/capitalizeHeaders.hs \