summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2015-07-02 22:09:04 -0700
committerJohn MacFarlane <jgm@berkeley.edu>2015-07-02 22:12:38 -0700
commit79764df2d5c75c63b92613316fcc8a9b8379f8cc (patch)
tree8d94fa2d3e0c3ae96ed980f8445e7be24efd59ea /Makefile
parentfbc5384ef809a156b6242758abb20d166a23d3cc (diff)
Added pandoc.1 to repository. Don't build as part of cabal build.
The process was too fragile. It made too many assumptions about available libraries (which failed sometimes when sandboxes were used). This is a low-tech solution. The only drawback is that `man/pandoc.1` is a generated file in the repository. It will need to be regenerated periodically when README changes.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 46c2be669..a2ed18d55 100644
--- a/Makefile
+++ b/Makefile
@@ -27,19 +27,26 @@ install: full
cabal copy
cabal register
-dist:
+dist: man/pandoc.1
cabal sdist
rm -rf "pandoc-${version}"
tar xvzf dist/pandoc-${version}.tar.gz
cd pandoc-${version}
cabal configure ${CABALARGS} && cabal build && cabal test && cd .. && rm -rf "pandoc-${version}"
-debpkg:
+debpkg: man/pandoc.1
./make_deb.sh
-osxpkg:
+osxpkg: man/pandoc.1
./make_osx_package.sh
+man/pandoc.1: README man/pandoc.1.template
+ pandoc $< -t man -s --template man/pandoc.1.template \
+ --filter man/capitalizeHeaders.hs \
+ --filter man/removeNotes.hs \
+ --filter man/removeLinks.hs \
+ -o $@
+
download_stats:
curl https://api.github.com/repos/jgm/pandoc/releases | \
jq '[.[] | .assets | .[] | {name: .name, download_count: .download_count}]'