summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2017-06-16 23:29:37 +0200
committerJohn MacFarlane <jgm@berkeley.edu>2017-06-17 07:45:28 +0200
commit9849ba7fd744f529f063e0802a18fa18c8433eeb (patch)
tree129de8b4a195535cd3868f43ba335c03c5d0b877 /Makefile
parent23f3c2d7b4796d1af742a74999ce67924bf2abb3 (diff)
Use Control.Monad.State.Strict throughout.
This gives 20-30% speedup and reduction of memory usage in most of the writers.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 65cf3146e..bd1ec4df5 100644
--- a/Makefile
+++ b/Makefile
@@ -16,7 +16,7 @@ test:
stack test --flag 'pandoc:embed_data_files' --fast --test-arguments='-j4 --hide-successes $(TESTARGS)'
bench:
- stack bench
+ stack bench --benchmark-arguments='$(BENCHARGS)'
weigh:
stack build --flag 'pandoc:weigh-pandoc' && stack exec weigh-pandoc