summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2017-12-27 09:34:30 -0800
committerJohn MacFarlane <jgm@berkeley.edu>2017-12-27 09:35:20 -0800
commit9ef3d77652e54e5d3872c1ccfe29918ae2a703b1 (patch)
tree0a2d9049400480d95c1c162980f4ab771e5b6c7a /Makefile
parent87c9771e9aaf604c5a76b701f7839c3ca1e52c2d (diff)
Makefile: Add 'pandoc-templates' target.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 46afc990d..5fc2b3d66 100644
--- a/Makefile
+++ b/Makefile
@@ -85,7 +85,15 @@ download_stats:
curl https://api.github.com/repos/jgm/pandoc/releases | \
jq -r '.[] | .assets | .[] | "\(.download_count)\t\(.name)"'
+pandoc-templates:
+ rm ../pandoc-templates/default.* ; \
+ cp data/templates/default.* ../pandoc-templates/ ; \
+ pushd ../pandoc-templates/ && \
+ git add default.* && \
+ git commit -m "Updated templates for pandoc $(version)" && \
+ popd
+
clean:
stack clean
-.PHONY: deps quick full haddock install clean test bench changes_github macospkg dist prof download_stats reformat lint weigh doc/lua-filters.md packages
+.PHONY: deps quick full haddock install clean test bench changes_github macospkg dist prof download_stats reformat lint weigh doc/lua-filters.md packages pandoc-templates