summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2013-06-25 10:39:08 -0700
committerJohn MacFarlane <jgm@berkeley.edu>2013-06-25 10:39:08 -0700
commitaee3f3f8f38ef54258b038cc9bf5b80cbf7812f3 (patch)
tree800244fede2b008086df7cb0af43443df85eee7e /Makefile
parentf869f7e08dad315945d52be3fcacf6ff0c05c5c1 (diff)
Updated Makefile.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index 7480babe9..52115818a 100644
--- a/Makefile
+++ b/Makefile
@@ -9,7 +9,7 @@ all:
prof:
cabal-dev configure --disable-tests --enable-library-profiling --enable-executable-profiling && cabal-dev build
-prep: submodules
+prep: submodules pandoc-types citeproc-hs
(cabal-dev --version || (cabal update && cabal install cabal-dev)) && \
cabal-dev update && \
cabal-dev install-deps --enable-library-profiling --enable-tests --enable-benchmarks
@@ -36,13 +36,13 @@ clean:
veryclean: clean
cabal-dev clean && rm -rf pandoc-types citeproc-hs
-# pandoc-types:
-# git clone https://github.com/jgm/pandoc-types && \
-# cabal-dev add-source pandoc-types
+pandoc-types:
+ git clone https://github.com/jgm/pandoc-types && \
+ cabal-dev add-source pandoc-types
-# citeproc-hs: pandoc-types
-# darcs get --lazy http://gorgias.mine.nu/repos/citeproc-hs && \
-# cabal-dev add-source citeproc-hs
+citeproc-hs: pandoc-types
+ darcs get --lazy http://gorgias.mine.nu/repos/citeproc-hs && \
+ cabal-dev add-source citeproc-hs
install:
cabal-dev install --enable-tests --enable-benchmarks