summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2017-03-04 13:12:29 +0100
committerJohn MacFarlane <jgm@berkeley.edu>2017-03-04 13:13:12 +0100
commit19d86132a88f19a8578b6a640a8eefa3e856fdfb (patch)
tree45bf643df2679c5bd17755a7e39e6e6671264076 /Makefile
parente256c8ce1778ff6fbb2e8d59556d48fb3c53393d (diff)
Makefile: Separate refactor and reformat targets.
Removed tools/refactor.sh.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 343fd8f4f..be3911d77 100644
--- a/Makefile
+++ b/Makefile
@@ -17,7 +17,10 @@ bench:
stack bench
refactor:
- ./tools/refactor.sh $(sourcefiles)
+ for f in $(sourcefiles); do echo $$f; hlint --refactor --refactor-options='-i' --cpp-file=`stack path --dist-dir`/build/autogen/cabal_macros.h $$f >/dev/null ; perl -i'' -ne 'if (/./) { print "\n" x $$n, $$_; $$n = 0 } else { $$n++ }' $$f; done
+
+reformat:
+ for f in $(sourcefiles); do echo $$f; stylish-haskell -i $$f ; done
changes_github:
pandoc --filter extract-changes.hs changelog -t markdown_github | sed -e 's/\\#/#/g' | pbcopy
@@ -57,4 +60,4 @@ download_stats:
clean:
stack clean
-.PHONY: deps quick full install clean test bench changes_github macospkg dist prof download_stats refactor
+.PHONY: deps quick full install clean test bench changes_github macospkg dist prof download_stats refactor reformat