summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2008-08-09 23:45:40 +0000
committerfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2008-08-09 23:45:40 +0000
commit28828979a6df073182bf039333cb46f8ad922b19 (patch)
tree02205c01432cb6bc737ee9c3268ecdba693fc2cf /Makefile
parente36ff78b5e6f4cfd0af50f6a599648c580d1a0b8 (diff)
Moved more of the build process from Makefile to Setup.hs:
+ tarball target now calls 'sdist' + Added to "Extra-source-files" and "Extra-tmp-files" in pandoc.cabal, so 'sdist' and 'clean' will work properly. + Makefile no longer generates man pages or reference.odt. + Setup.hs now generates man pages in a postbuild hook. + Added dependency-checking to Setup.hs, so it only rebuilds things that need rebuilding. git-svn-id: https://pandoc.googlecode.com/svn/trunk@1389 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile14
1 files changed, 2 insertions, 12 deletions
diff --git a/Makefile b/Makefile
index 413fdc02f..bfbceca52 100644
--- a/Makefile
+++ b/Makefile
@@ -90,14 +90,6 @@ all: build-program
sh ./markdown2pdf $< || rm -f $@
%.txt: %
perl -p -e 's/\n/\r\n/' $< > $@ || rm -f $@ # convert to DOS line endings
-%.1: %.1.md $(MAIN)
- ./$(MAIN) -s -S -w man $< >$@ || rm -f $@
-
-cleanup_files+=$(ODTREF)
-$(ODTREF): $(addprefix $(ODTSTYLES)/, meta.xml styles.xml content.xml mimetype \
- settings.xml Thumbnails META-INF)
- cd $(ODTSTYLES) ; \
- zip -9 -q -r $(notdir $@) * -x $(notdir $@)
.PHONY: configure
cleanup_files+=Setup.hi Setup.o $(BUILDCMD) $(BUILDVARS)
@@ -272,10 +264,8 @@ tarball:=$(PKGID).tar.gz
cleanup_files+=$(tarball)
tarball: $(tarball)
$(tarball):
- svn export . $(PKGID)
- $(MAKE) -C $(PKGID) wrappers
- tar cvzf $(tarball) $(PKGID)
- -rm -rf $(PKGID)
+ $(BUILDCMD) sdist
+ cp $(BUILDDIR)/$(tarball) .
.PHONY: deb
deb_name:=$(shell grep ^Package debian/control | cut -d' ' -f2 | head -n 1)