summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2015-07-01 16:29:44 -0700
committerJohn MacFarlane <jgm@berkeley.edu>2015-07-01 16:29:44 -0700
commit28cb50503b2f9428de34dee0d62f2e46f1c0fa59 (patch)
tree2e6d0f770ac5892b66368c2fa2a6310a57b71fda /Makefile
parent958a615b759aaa45333bac7f12a2a35b2d8c8b34 (diff)
Generate man page in cabal build process and include in data/.
The pandoc.1 man page is generated automatically after the cabal build process. It goes in `data/pandoc.1`. It can be obtained by the user who installs pandoc via cabal thus: pandoc --print-default-data-file pandoc.1 > pandoc.1
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile12
1 files changed, 1 insertions, 11 deletions
diff --git a/Makefile b/Makefile
index 265786a6c..46c2be669 100644
--- a/Makefile
+++ b/Makefile
@@ -40,21 +40,11 @@ debpkg:
osxpkg:
./make_osx_package.sh
-man/man1/pandoc.1: README man/pandoc.1.template
- @[ -n "$(pandoc)" ] || \
- (echo "Could not find pandoc in dist/" && exit 1)
- $(pandoc) $< -t man -s --template man/pandoc.1.template \
- --filter man/capitalizeHeaders.hs \
- --filter man/removeNotes.hs \
- --filter man/removeLinks.hs \
- -o $@
-
download_stats:
curl https://api.github.com/repos/jgm/pandoc/releases | \
jq '[.[] | .assets | .[] | {name: .name, download_count: .download_count}]'
clean:
cabal clean
- -rm man/man1/pandoc.1
-.PHONY: deps quick full install man clean test bench haddock osxpkg dist bindist prof download_stats
+.PHONY: deps quick full install clean test bench osxpkg dist prof download_stats