summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-11-26 21:27:59 +0000
committerfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-11-26 21:27:59 +0000
commit3dfe4cb708ac14369aab19383c1008b2cf4adbc4 (patch)
treed1e3341eff7a7a1eae1c796344a19e28e1b8ce69 /Makefile
parent99d8d45b744c98f08e12296667efebef52bfc8b6 (diff)
Makefile: Add .exe extension to BUILDCMD if building on Windows.
git-svn-id: https://pandoc.googlecode.com/svn/trunk@1096 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index eb132eade..2563f78c9 100644
--- a/Makefile
+++ b/Makefile
@@ -9,7 +9,6 @@ MANDIR := man
TESTDIR := tests
BUILDDIR := dist
BUILDCONF := .setup-config
-BUILDCMD := ./setup
BUILDVARS := vars
CONFIGURE := configure
@@ -28,6 +27,7 @@ WRAPPERS := html2markdown markdown2pdf hsmarkdown
# Add .exe extensions if we're running Windows/Cygwin.
EXTENSION := $(shell uname | tr '[:upper:]' '[:lower:]' | \
sed -ne 's/^cygwin.*$$/\.exe/p')
+BUILDCMD := $(addsuffix $(EXTENSION), ./setup)
EXECS := $(addsuffix $(EXTENSION),$(EXECSBASE))
PROGS := $(EXECS) $(WRAPPERS)
MAIN := $(firstword $(EXECS))