summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2017-11-11 15:26:24 -0800
committerJohn MacFarlane <jgm@berkeley.edu>2017-11-11 15:26:24 -0800
commit6b75d6e08ccb52dd6dce7d1387faa19c3e7f8258 (patch)
tree8e93c067ef818b4acfa88f8fdcf255b79c45e318 /Makefile
parent6174b5bea5e8c4c35c191bd62f1f42e4d7fce69e (diff)
Use lua filter to generate man page from MANUAL.
Instead of three Haskell filters. This is easier and faster.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index b2375fbe9..49689365e 100644
--- a/Makefile
+++ b/Makefile
@@ -55,10 +55,8 @@ pandoc-$(version)-windows.msi:
rm pandoc.msi
man/pandoc.1: MANUAL.txt man/pandoc.1.template
- pandoc $< -t man -s --template man/pandoc.1.template \
- --filter man/capitalizeHeaders.hs \
- --filter man/removeNotes.hs \
- --filter man/removeLinks.hs \
+ pandoc $< -f markdown-smart -t man -s --template man/pandoc.1.template \
+ --lua-filter man/manfilter.lua \
--variable version="pandoc $(version)" \
-o $@