summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-12-08 23:00:40 +0000
committerfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-12-08 23:00:40 +0000
commit7a68e64162972aaa3ceab0c3ef47dbdfebdf4151 (patch)
tree8713e9cdccbb87eb68b150b8caec41632f6aff20 /Makefile
parent0bf553142c63696a9a0b3900c1fd32b658c34a08 (diff)
Use \{0,1\} instead of \? in sed, so it works on BSD/Mac OSX too.
git-svn-id: https://pandoc.googlecode.com/svn/trunk@1144 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index a42bd7a1e..168bd744b 100644
--- a/Makefile
+++ b/Makefile
@@ -18,7 +18,7 @@ CONFIGURE := configure
PKG := $(shell sed -ne 's/^[Nn]ame:[[:space:]]*//p' $(CABAL) | tr A-Z a-z)
VERSION := $(shell sed -ne 's/^[Vv]ersion:[[:space:]]*//p' $(CABAL))
PKGID := $(PKG)-$(VERSION)
-EXECSBASE := $(shell sed -ne 's/^[Ee]xecutable:\?[[:space:]]*//p' $(CABAL))
+EXECSBASE := $(shell sed -ne 's/^[Ee]xecutable:\{0,1\}[[:space:]]*//p' $(CABAL))
#-------------------------------------------------------------------------------
# Install targets