summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2017-12-29 16:41:51 -0800
committerJohn MacFarlane <jgm@berkeley.edu>2017-12-29 16:41:51 -0800
commit81b0b208278ea8982d6581bda0dc922c466df2a9 (patch)
tree6f7d39e01586780dfd0400aa709e3dacd94fbe70 /Makefile
parent0d968c4bbbd9e9b718d6fa63814419866e670c95 (diff)
Generate README.md from template and MANUAL.txt.
`make README.md` will generate the README.md after changes to MANUAL.txt have been made.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index f0e0d1b8a..b48bd9287 100644
--- a/Makefile
+++ b/Makefile
@@ -82,6 +82,10 @@ doc/lua-filters.md: tools/ldoc.ltp data/pandoc.lua tools/update-lua-docs.lua
-o $@ $@.tmp
rm $@.tmp
+README.md: README.template MANUAL.txt tools/update-readme.lua
+ pandoc --lua-filter tools/update-readme.lua --reference-links \
+ --reference-location=section $< -o $@
+
download_stats:
curl https://api.github.com/repos/jgm/pandoc/releases | \
jq -r '.[] | .assets | .[] | "\(.download_count)\t\(.name)"'