summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2015-11-15 08:19:26 -0800
committerJohn MacFarlane <jgm@berkeley.edu>2015-11-15 08:19:26 -0800
commit8914b6530abc26cf5cc9e36ba76826f31bd965b3 (patch)
tree758838e1f0f121e912e0d913f6c19bd74fa6e5ad /Makefile
parent07e1234c3bbedea38793891215006c0e03d6582c (diff)
Added 'make changes_github' and 'make changes', updated release checklist.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index aa11fd363..0ae248882 100644
--- a/Makefile
+++ b/Makefile
@@ -23,9 +23,12 @@ test:
bench:
cabal bench
-changes:
+changes_github:
pandoc --filter extract-changes.hs changelog -t markdown_github | pbcopy
+changes:
+ pandoc --filter extract-changes.hs changelog -t markdown | pbcopy
+
install: full
cabal copy
cabal register
@@ -61,4 +64,4 @@ download_stats:
clean:
cabal clean
-.PHONY: deps quick full install clean test bench changes osxpkg dist prof download_stats
+.PHONY: deps quick full install clean test bench changes changes_github osxpkg dist prof download_stats