summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2017-12-28 16:39:30 -0800
committerJohn MacFarlane <jgm@berkeley.edu>2017-12-28 16:39:30 -0800
commit90292067158ea59af0df036a4fefaf06a19acaa5 (patch)
tree7117c3a94bf87913657125abac0415088972c15e /Makefile
parentc45f3fe47f505a8add7b27d8d64fb644697a0a70 (diff)
Makefile tweaks
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index e636e418b..f0e0d1b8a 100644
--- a/Makefile
+++ b/Makefile
@@ -33,7 +33,7 @@ lint:
for f in $(SOURCEFILES); do echo $$f; hlint --verbose --refactor --refactor-options='-i -s' $$f; done
changes_github:
- pandoc --filter tools/extract-changes.hs changelog -t gfm+hard_line_breaks | sed -e 's/\\#/#/g' | pbcopy
+ pandoc --filter tools/extract-changes.hs changelog -t gfm --wrap=none | sed -e 's/\\#/#/g' | pbcopy
dist: man/pandoc.1
cabal sdist
@@ -105,4 +105,4 @@ update-website:
clean:
stack clean
-.PHONY: deps quick full haddock install clean test bench changes_github macospkg dist prof download_stats reformat lint weigh doc/lua-filters.md packages pandoc-templates trypandoc
+.PHONY: deps quick full haddock install clean test bench changes_github macospkg dist prof download_stats reformat lint weigh doc/lua-filters.md packages pandoc-templates trypandoc update-website