summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2006-12-28 02:20:09 +0000
committerfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2006-12-28 02:20:09 +0000
commita1a30d69bd83e57e494cd3ca5077086077731998 (patch)
tree8193378eb51d13a20cf9f28ce479af431d3dcba4 /Makefile
parenta1539d9ab8141ab11add5b304792e7c9bc7a363a (diff)
+ Removed the convenience symlinks (which don't work on Windows under
Cygwin, due to Windows' lack of true symbolic links). + Modified the wrappers to use 'pandoc' instead of the symlinks. + Modified the Makefile to remove all references to the symlinks. + Removed code from Main.hs that made pandoc's behavior depend on the name of the calling program. + Added code to Main.hs that sets default reader and writer based on extensions of input and output filenames (if provided). (Thanks to roktas for the idea.) + Modified README and man pages accordingly. + Removed WINDOWS-README target from Makefile. It is no longer needed now that we don't have the symlinks. git-svn-id: https://pandoc.googlecode.com/svn/trunk@295 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile19
1 files changed, 3 insertions, 16 deletions
diff --git a/Makefile b/Makefile
index 5ea1ae24d..e6e87cea2 100644
--- a/Makefile
+++ b/Makefile
@@ -26,8 +26,6 @@ EXECSBASE := $(shell sed -ne 's/^[Ee]xecutable:[[:space:]]*//p' $(CABAL).in)
# Install targets
#-------------------------------------------------------------------------------
WRAPPERS := web2markdown markdown2pdf
-SYMLINKS := markdown2html markdown2latex markdown2s5 markdown2rst \
- markdown2rtf html2markdown latex2markdown rst2markdown
# Add .exe extensions if we're running Windows/Cygwin.
EXTENSION := $(shell uname | tr '[:upper:]' '[:lower:]' | \
sed -ne 's/^cygwin.*$$/\.exe/p')
@@ -96,12 +94,6 @@ all: build-program
templates: $(SRCDIR)/templates
$(MAKE) -C $(SRCDIR)/templates
-.PHONY: symlinks
-cleanup_files+=$(SYMLINKS)
-symlinks: $(SYMLINKS)
-$(SYMLINKS): $(MAIN)
- ln -sf ./$(MAIN) $@
-
define generate-shell-script
echo "Generating $@..."; \
awk ' \
@@ -141,7 +133,7 @@ build: configure
$(BUILDCMD) build
.PHONY: build-exec
-build-exec: $(PROGS) $(SYMLINKS)
+build-exec: $(PROGS)
cleanup_files+=$(EXECS)
$(EXECS): build
for f in $@; do \
@@ -201,9 +193,8 @@ install-exec: build-exec
fi; \
$(INSTALL_PROGRAM) $$f $(BINPATH)/; \
done
- cd $(BINPATH); for f in $(SYMLINKS); do ln -sf $(MAIN) $$f; done
uninstall-exec:
- -for f in $(notdir $(PROGS) $(SYMLINKS)); do rm -f $(BINPATH)/$$f; done ;
+ -for f in $(notdir $(PROGS)); do rm -f $(BINPATH)/$$f; done ;
# Program + user documents installation.
.PHONY: install-program uninstall-program
@@ -295,15 +286,11 @@ $(osx_dmg_name): $(osx_pkg_name)
.PHONY: win-pkg
win_pkg_name:=$(RELNAME).zip
-win_docs:=COPYING.txt COPYRIGHT.txt BUGS.txt README-WINDOWS.txt README-WINDOWS.html
+win_docs:=COPYING.txt COPYRIGHT.txt BUGS.txt README.txt README.html
cleanup_files+=$(win_pkg_name) $(win_docs)
win-pkg: $(win_pkg_name)
$(win_pkg_name): $(THIS).exe $(win_docs)
zip -r $(win_pkg_name) $(THIS).exe $(win_docs)
-cleanup_files+=README-WINDOWS
-README-WINDOWS: README
- sed -e '/^Requirements/,/^\[fancyvrb\]:/ d' \
- -e '/^Character encodings/,/mysite.com$$/ d' $< > $@
.PHONY: test test-markdown
test: $(MAIN)