summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2015-11-15 23:15:51 -0800
committerJohn MacFarlane <jgm@berkeley.edu>2015-11-15 23:15:51 -0800
commita52b18807a6f175e3411df53315346cf23250d07 (patch)
tree24528026d7b4981acccec2f3622b798104801aeb /Makefile
parentb59d0fb6bd26365bddda36e434cb877bae1d156e (diff)
'make dist' - use stack to build from tarball.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 1c9942959..5dfb5565b 100644
--- a/Makefile
+++ b/Makefile
@@ -35,7 +35,7 @@ dist: man/pandoc.1
rm -rf "pandoc-${version}"
tar xvzf dist/pandoc-${version}.tar.gz
cd pandoc-${version}
- cabal configure ${CABALARGS} && cabal build && cabal test && cd .. && rm -rf "pandoc-${version}"
+ stack setup && stack test && cd .. && rm -rf "pandoc-${version}"
.travis.yml: pandoc.cabal make_travis_yml.hs
runghc make_travis_yml.hs $< > $@