summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-01-04 17:23:30 +0000
committerfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-01-04 17:23:30 +0000
commitb6663c7e1675c6ceb5b92d4ec21bc09b240b6ea9 (patch)
treedb34d2b7aab263172bc9707bcf6441223355f956 /Makefile
parentb770a9f009fbd2f082af9fc2a5ad00f80e5150ad (diff)
Changed test-markdown target in Makefile: Now it will find any
markdown test suites in the 'test' directory (subdirectories beginning with 'MarkdownTest_') and run them all. This allows us to have multiple test suites, e.g. for 1.0 and for a beta version. git-svn-id: https://pandoc.googlecode.com/svn/trunk@414 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index fd75cdc85..809adeeaa 100644
--- a/Makefile
+++ b/Makefile
@@ -296,10 +296,16 @@ $(win_pkg_name): $(THIS).exe $(win_docs)
test: $(MAIN)
@cd $(TESTDIR) && perl runtests.pl -s $(PWD)/$(MAIN)
compat:=$(PWD)/hsmarkdown
+markdown_test_dirs:=$(wildcard $(TESTDIR)/MarkdownTest_*)
test-markdown: $(MAIN) $(compat)
- @# set path so that wrapper can be run even if pandoc not installed
- @PATH=$(PWD):$$PATH; export PATH; cd $(TESTDIR)/MarkdownTest_1.0.3 && \
- perl MarkdownTest.pl -s $(compat) -tidy \
+ @for suite in $(markdown_test_dirs); do \
+ ( \
+ suite_version=$$(echo $$suite | sed -e 's/.*_//');\
+ echo "\nRunning Markdown test suite version $${suite_version}.";\
+ PATH=$(PWD):$$PATH; export PATH; cd $$suite && \
+ perl MarkdownTest.pl -s $(compat) -tidy ; \
+ ) \
+ done
# Stolen and slightly improved from a GPLed Makefile. Credits to John Meacham.
src_all:=$(shell find $(SRCDIR) -type f -name '*hs' | egrep -v '^\./(_darcs|lib|test)/')