summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2015-10-08 13:39:32 -0700
committerJohn MacFarlane <jgm@berkeley.edu>2015-10-08 13:39:32 -0700
commitc13494c8089fcbac70c83967ceaa5e88cdd30fac (patch)
treeaebb17c50f06856ee1e648b034f95405a0ce6db0 /Makefile
parent00e2ae8a675f7e1605048e096e3ae70776b0030e (diff)
New .travis.yml.
Autgenerated using make_travis_yml.hs. This script has been modified to add GHCOPTS. 'make .travis.yml' regenerates it based on the tested-with field of the cabal file.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index a44085420..3a52e3bd0 100644
--- a/Makefile
+++ b/Makefile
@@ -34,6 +34,9 @@ dist: man/pandoc.1
cd pandoc-${version}
cabal configure ${CABALARGS} && cabal build && cabal test && cd .. && rm -rf "pandoc-${version}"
+.travis.yml: pandoc.cabal
+ runghc make_travis_yml.hs $< > $@
+
debpkg: man/pandoc.1
./make_deb.sh