summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorAlbert Krewinkel <albert+github@zeitkraut.de>2017-09-30 16:45:31 +0200
committerJohn MacFarlane <jgm@berkeley.edu>2017-09-30 10:45:31 -0400
commitc363519302e11daab2187445f39a15ce6ef19137 (patch)
tree37d22cce642757f913126da96b483c75ac1210f8 /Makefile
parent950c68c83562d35bf1f93a213a33f227d1948451 (diff)
Provide make target to update lua module docs (#3946)
The pandoc module documentation in doc/lua-filters.md was automatically generated from `data/pandoc.lua`. A make target is provided which uses a lua filter to update the documentation.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 3931dd9d8..52e6e8fb1 100644
--- a/Makefile
+++ b/Makefile
@@ -62,6 +62,14 @@ man/pandoc.1: MANUAL.txt man/pandoc.1.template
--variable version="pandoc $(version)" \
-o $@
+doc/lua-filters.md: tools/ldoc.ltp data/pandoc.lua tools/update-lua-docs.lua
+ cp $@ $@.tmp
+ pandoc -t markdown --columns=64 --atx-headers \
+ -f markdown -t markdown --standalone\
+ --lua-filter tools/update-lua-docs.lua \
+ -o $@ $@.tmp
+ rm $@.tmp
+
download_stats:
curl https://api.github.com/repos/jgm/pandoc/releases | \
jq -r '.[] | .assets | .[] | "\(.download_count)\t\(.name)"'
@@ -69,4 +77,4 @@ download_stats:
clean:
stack clean
-.PHONY: deps quick full haddock install clean test bench changes_github macospkg dist prof download_stats reformat lint weigh
+.PHONY: deps quick full haddock install clean test bench changes_github macospkg dist prof download_stats reformat lint weigh doc/lua-filters.md