summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-08-15 21:51:38 +0000
committerfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-08-15 21:51:38 +0000
commitc3b27348ccecbfd8f2079bc32ca555f1a915b331 (patch)
tree8b18924592d8dcc066467f6348852d9c3c457099 /Makefile
parent77f13e23da9f5f2d7f20ff81dbe557a7bcabe36b (diff)
Simplified Makefile install-all and uninstall-all targets.
git-svn-id: https://pandoc.googlecode.com/svn/trunk@853 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index e38cea785..43741e890 100644
--- a/Makefile
+++ b/Makefile
@@ -152,7 +152,7 @@ haddock: build-lib-doc
cleanup_files+=html
html/: configure
-rm -rf html
- $(BUILDCMD) haddock && mv $(BUILDDIR)/doc/html .
+ $(BUILDCMD) haddock && cp -r $(BUILDDIR)/doc/html .
.PHONY: build-all
build-all: build-program build-lib-doc
@@ -203,9 +203,9 @@ uninstall-exec:
install-program: install-exec install-doc
uninstall-program: uninstall-exec uninstall-doc
-# Install everything.
.PHONY: install-all uninstall-all
-install-all: build-exec install-doc install-lib-doc
+# Install libraries
+install-all: build-all install-doc install-lib-doc
# Install the library (+ main executable) and register it.
destdir=$(DESTDIR); \
# Older Cabal versions have no '--destdir' option.
@@ -219,7 +219,7 @@ install-all: build-exec install-doc install-lib-doc
# Note that, we are in the position of having to install the wrappers
# separately, as Cabal installs the main exec along with the library.
$(call install-executable-files,$(WRAPPERS),$(BINPATH))
-uninstall-all: uninstall-exec uninstall-doc uninstall-lib-doc
+uninstall-all: uninstall-program uninstall-lib-doc
-pkg_id="$(NAME)-$(VERSION)"; \
libdir=$$($(GHC_PKG) field $$pkg_id library-dirs 2>/dev/null | \
sed 's/^library-dirs: *//'); \