summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2014-08-16 17:14:33 -0700
committerJohn MacFarlane <jgm@berkeley.edu>2014-08-16 17:14:33 -0700
commitfd8ad0413bf7b782142558c112862a8f99b9796d (patch)
tree58c6e99ed18bb5ad6d223ba619297e1898a3a078 /Makefile
parent118cdad8e893a01d1da84ed3fb0aa758425f523b (diff)
Makefile: Added 'quick' target.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 105160760..0d5b518b4 100644
--- a/Makefile
+++ b/Makefile
@@ -9,6 +9,10 @@ CABALARGS=-fmake-pandoc-man-pages --enable-tests --enable-benchmarks
all: build test
+quick:
+ cabal configure --enable-tests --disable-optimization
+ cabal build
+
deps:
cabal install ${OPTIONS} ${CABALARGS} --only-dependencies