summaryrefslogtreecommitdiff
path: root/deb
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2015-10-24 22:52:41 -0700
committerJohn MacFarlane <jgm@berkeley.edu>2015-10-24 22:52:41 -0700
commit31e46c1cc18da0563a7a84607ff75b049d16f247 (patch)
tree4df2f3eb4011e10f2616cc968a5ed438d2d0e2e7 /deb
parent34bcaed62a9eb32281ed99d10de96c6054c35367 (diff)
Added Vagrantfile for building deb in vm.
This should help in automating binary package creation. 'make package' will make the package. 'make package COMMIT=blah' will make the package from commit blah.
Diffstat (limited to 'deb')
-rw-r--r--deb/Makefile8
-rw-r--r--deb/Vagrantfile73
2 files changed, 81 insertions, 0 deletions
diff --git a/deb/Makefile b/deb/Makefile
new file mode 100644
index 000000000..7d067ef70
--- /dev/null
+++ b/deb/Makefile
@@ -0,0 +1,8 @@
+COMMIT?=HEAD
+
+.PHONY: package
+
+package:
+ vagrant up
+ vagrant ssh -c 'rm -rf pandoc && git clone https://github.com/jgm/pandoc && cd pandoc && git checkout -b work $(COMMIT) && git submodule update --init && ./make_deb.sh && cp *.deb /vagrant_data/'
+ vagrant halt
diff --git a/deb/Vagrantfile b/deb/Vagrantfile
new file mode 100644
index 000000000..f0f2697ca
--- /dev/null
+++ b/deb/Vagrantfile
@@ -0,0 +1,73 @@
+# -*- mode: ruby -*-
+# vi: set ft=ruby :
+
+# All Vagrant configuration is done below. The "2" in Vagrant.configure
+# configures the configuration version (we support older styles for
+# backwards compatibility). Please don't change it unless you know what
+# you're doing.
+Vagrant.configure(2) do |config|
+ # The most common configuration options are documented and commented below.
+ # For a complete reference, please see the online documentation at
+ # https://docs.vagrantup.com.
+
+ # Every Vagrant development environment requires a box. You can search for
+ # boxes at https://atlas.hashicorp.com/search.
+ config.vm.box = "ubuntu/trusty64"
+
+ # Disable automatic box update checking. If you disable this, then
+ # boxes will only be checked for updates when the user runs
+ # `vagrant box outdated`. This is not recommended.
+ # config.vm.box_check_update = false
+
+ # Create a forwarded port mapping which allows access to a specific port
+ # within the machine from a port on the host machine. In the example below,
+ # accessing "localhost:8080" will access port 80 on the guest machine.
+ # config.vm.network "forwarded_port", guest: 80, host: 8080
+
+ # Create a private network, which allows host-only access to the machine
+ # using a specific IP.
+ # config.vm.network "private_network", ip: "192.168.33.10"
+
+ # Create a public network, which generally matched to bridged network.
+ # Bridged networks make the machine appear as another physical device on
+ # your network.
+ # config.vm.network "public_network"
+
+ # Share an additional folder to the guest VM. The first argument is
+ # the path on the host to the actual folder. The second argument is
+ # the path on the guest to mount the folder. And the optional third
+ # argument is a set of non-required options.
+ config.vm.synced_folder ".", "/vagrant_data"
+
+ # Provider-specific configuration so you can fine-tune various
+ # backing providers for Vagrant. These expose provider-specific options.
+ # Example for VirtualBox:
+ #
+ config.vm.provider "virtualbox" do |vb|
+ # Display the VirtualBox GUI when booting the machine
+ # vb.gui = true
+
+ # Customize the amount of memory on the VM:
+ vb.memory = "4096"
+ end
+ #
+ # View the documentation for the provider you are using for more
+ # information on available options.
+
+ # Define a Vagrant Push strategy for pushing to Atlas. Other push strategies
+ # such as FTP and Heroku are also available. See the documentation at
+ # https://docs.vagrantup.com/v2/push/atlas.html for more information.
+ # config.push.define "atlas" do |push|
+ # push.app = "YOUR_ATLAS_USERNAME/YOUR_APPLICATION_NAME"
+ # end
+
+ # Enable provisioning with a shell script. Additional provisioners such as
+ # Puppet, Chef, Ansible, Salt, and Docker are also available. Please see the
+ # documentation for more information about their specific syntax and use.
+ config.vm.provision "shell", inline: <<-SHELL
+ wget -q -O- https://s3.amazonaws.com/download.fpcomplete.com/debian/fpco.key | sudo apt-key add -
+ echo 'deb http://download.fpcomplete.com/ubuntu/trusty stable main'|sudo tee /etc/apt/sources.list.d/fpco.list
+ sudo apt-get update
+ sudo apt-get install -y stack build-essential debhelper dh-make
+ SHELL
+end