summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorClint Adams <clint@debian.org>2016-10-27 21:00:29 -0400
committerClint Adams <clint@debian.org>2016-10-27 21:00:29 -0400
commit41f25e409f8e12d0f0b630d8f7d3e25d9f81d5bf (patch)
tree08a4812d569f9fa33f472cd766ae6a85e5a1598e /debian/rules
parent38367800bc654820fdad6e13f85228af6ea7af71 (diff)
Revert "Temporarily build-depend on ghc 8 and haskell-devscripts 0.13"
This reverts commit 32c0a8fcb9ba470d0f5f38aafa2310d6c18d97f4.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index c88810f97..954266566 100755
--- a/debian/rules
+++ b/debian/rules
@@ -106,7 +106,7 @@ strip-ghc-deps = $(foreach dep,$2,$(call expand-ghc-dep,$1,$(word 1,$(subst $(co
expand-ghc-deps = $(foreach dep,$2,$(call expand-ghc-dep,$1,$(word 1,$(subst $(comma),$(space),$(dep))),$(word 2,$(subst $(comma),$(space),$(dep))),$(word 3,$(subst $(comma),$(space),$(dep))),$(word 4,$(subst $(comma),$(space),$(dep))),$(word 5,$(subst $(comma),$(space),$(dep)))))
# Needed by upstream build process
-CDBS_BUILD_DEPENDS +=, ghc (>= 8.0), alex, happy
+CDBS_BUILD_DEPENDS +=, ghc, alex, happy
CDBS_BUILD_DEPENDS += $(call expand-ghc-deps,dev,$(deps-ghc))
# FIXME: enable, set DEB_ENABLE_TESTS = yes, and configure with -ftests
#CDBS_BUILD_DEPENDS += $(call expand-ghc-deps,dev,$(deps-ghc-test))
@@ -117,7 +117,7 @@ CDBS_BUILD_DEPENDS_INDEP +=, $(call strip-ghc-deps,doc,$(deps-ghc) $(deps-ghc-do
# Needed for our packaging
# * recent haskell-devscripts needed for version-less datadir
-CDBS_BUILD_DEPENDS +=, haskell-devscripts (>= 0.13)
+CDBS_BUILD_DEPENDS +=, haskell-devscripts (>= 0.8.19~)
# Needed (always/often/seldom) at runtime
# texlive-* needed for PDF output