summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJonas Smedegaard <dr@jones.dk>2016-06-01 12:48:19 +0200
committerJonas Smedegaard <dr@jones.dk>2016-06-01 12:48:19 +0200
commit44a01c5f56f5bb69bcd7bf6fdb92593ec90c564f (patch)
treee02eb3ec6df16f536415fe075f91bf35c06dc620 /debian/rules
parentd7b1dd93a943405afbbfda6ff089a1436ebc5038 (diff)
Modernize copyright-check. Tighten to build-depend versioned on cdbs.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules19
1 files changed, 2 insertions, 17 deletions
diff --git a/debian/rules b/debian/rules
index 26f775f42..5cfaeb994 100755
--- a/debian/rules
+++ b/debian/rules
@@ -28,23 +28,8 @@ pkg-data = $(pkg)-data
# ABI by default follows upstream version (without repackaging suffix)
abi = $(DEB_UPSTREAM_TARBALL_VERSION)
-# extract metadata from images, fonts and archives before copyright check
-CDBS_BUILD_DEPENDS +=, libimage-exiftool-perl, libregexp-assemble-perl
-CDBS_BUILD_DEPENDS +=, libipc-system-simple-perl, lcdf-typetools
-local_inspection_regex = png|jpg|jpeg|gif|ttf|otf|docx|odt|epub
-DEB_COPYRIGHT_CHECK_IGNORE_REGEX = ^((.*/)?[^/]+\.($(local_inspection_regex))|debian/(changelog|copyright(|_hints|_newhints)))$$
-debian/stamp-copyright-check: debian/stamp-extract-copyright
-debian/stamp-extract-copyright:
- find * -type f -regextype posix-extended \
- -regex '.*\.($(local_inspection_regex))' \
- -print0 | perl -0 debian/print-metadata.pl
- touch $@
-pre-build:: clean-extracted-copyright-during-build
-clean-extracted-copyright-during-build: debian/stamp-copyright-check
- find -type f -name '*.metadata_dump' -delete
-clean::
- find -type f -name '*.metadata_dump' -delete
- rm -f debian/stamp-extract-copyright
+DEB_COPYRIGHT_EXTRACT_EXTS = png jpg jpeg gif ttf otf docx odt epub
+DEB_COPYRIGHT_CHECK_MERGE_SAME_LICENSE = yes
DEB_INSTALL_MANPAGES_$(pkg) = man/pandoc.1