summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-11-25 01:51:36 +0000
committerfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-11-25 01:51:36 +0000
commit99d8d45b744c98f08e12296667efebef52bfc8b6 (patch)
treecce59f311e629ce0b823e95f09a3e46d7f409dee /debian/rules
parent3703f625be18201be1e6bb87235ada1b39029290 (diff)
+ Makefile now checks GHC version. If GHC is 6.6, pandoc.cabal.ghc66
is copied to pandoc.cabal, and the old pandoc.cabal is copied to pandoc.cabal.orig. Otherwise, pandoc.cabal is copied to pandoc.cabal.orig but otherwise unmodified. This way, the Makefile will work properly with either GHC 6.6 or 6.8. + The changes in debian/rules from r1066 have been reverted, since they are no longer needed. Also, debian/rules has been converted to UTF-8. + INSTALL instructions have been updated accordingly. git-svn-id: https://pandoc.googlecode.com/svn/trunk@1095 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules19
1 files changed, 3 insertions, 16 deletions
diff --git a/debian/rules b/debian/rules
index 13705683e..8e3dc240f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,7 @@
#!/usr/bin/make -f
#
# debian/rules for pandoc.
-# Copyright © 2006 Recai Oktaþ <roktasATdebian.org>
+# Copyright © 2006 Recai Oktaş <roktasATdebian.org>
#
# This file is based on John Goerzen's Cabal Debian template.
# See http://www.n-heptane.com/nhlab/repos/cabalDebianTemplate/
@@ -33,21 +33,8 @@ endif
# Export all variables which will be used in various stages of build process.
export PREFIX DESTDIR DATADIR DOCDIR HCFLAGS
-# Special code dealing with ghc 6.6 -> 6.8 transition.
-.PHONY: cabalbackup cabalrestore
-cabalbackup: $(THIS).cabal.ghccurrent
-$(THIS).cabal.ghccurrent:
- if [ -f $(THIS).cabal.ghc66 ]; then \
- mv $(THIS).cabal $(THIS).cabal.ghccurrent; \
- cp $(THIS).cabal.ghc66 $(THIS).cabal; \
- fi
-cabalrestore:
- if [ -f $(THIS).cabal.ghc66 ] && [ -f $(THIS).cabal.ghccurrent ]; then \
- mv $(THIS).cabal.ghccurrent $(THIS).cabal; \
- fi
-
configure: configure-stamp
-configure-stamp: cabalbackup
+configure-stamp:
dh_testdir
$(MAKE) configure
@@ -133,5 +120,5 @@ binary-arch: build install
dh_md5sums -a
dh_builddeb -a
-binary: binary-indep binary-arch cabalrestore
+binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install build-indep install-indep