summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJonas Smedegaard <dr@jones.dk>2017-07-13 13:19:48 +0200
committerJonas Smedegaard <dr@jones.dk>2017-07-21 18:43:06 +0200
commit835ef3b66a38dbec1869fa45a02397e898240429 (patch)
tree4a11cdedcd82d637ed266abb497c4350ddfeca16 /debian
parente5ce0b3b7d1aaaa0f717cdbfaf5d216d86ea7991 (diff)
Tidy rules file: Rename variables deps-ghc* → ghc-deps*.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules112
1 files changed, 56 insertions, 56 deletions
diff --git a/debian/rules b/debian/rules
index ed7eaeb63..2f0f796f2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -29,73 +29,73 @@ strip-ghc-deps = $(foreach dep,$2,$(call expand-ghc-dep,$1,$(word 1,$(subst $(co
expand-ghc-deps = $(foreach dep,$2,$(call expand-ghc-dep,$1,$(word 1,$(subst $(comma),$(space),$(dep))),$(word 2,$(subst $(comma),$(space),$(dep))),$(word 3,$(subst $(comma),$(space),$(dep))),$(word 4,$(subst $(comma),$(space),$(dep))),$(word 5,$(subst $(comma),$(space),$(dep)))))
# Haskell dependencies for any build from pandoc.cabal
-deps-ghc += unordered-containers,<<,3
-deps-ghc += parsec3,<<,3.2
-deps-ghc += mtl,>=,2.2,<<,2.3
-deps-ghc += network,>=,2.6
-deps-ghc += network-uri,<<,2.7
-deps-ghc += text,<<,1.3
-deps-ghc += zip-archive,<<,0.4
-deps-ghc += http,<<,1:4000.4
-deps-ghc += texmath,>=,0.9,<<,0.10
-deps-ghc += xml,<<,1.4
-deps-ghc += random,<<1.2
-deps-ghc += extensible-exceptions,<<,0.2
-deps-ghc += pandoc-types,>=,1.17,<<,1.18
-deps-ghc += aeson,>=,0.7.0.5,<<,1.1
-deps-ghc += tagsoup,<<,0.15
-deps-ghc += base64-bytestring,<<,1.1
-deps-ghc += zlib,<<,0.7
-deps-ghc += highlighting-kate,>=,0.6.2,<<,0.7
-deps-ghc += data-default,<<,0.8
-deps-ghc += temporary,<<,1.3
-deps-ghc += blaze-html,<<,0.9
-deps-ghc += blaze-markup,<<,0.8
-deps-ghc += yaml,<<,0.9
-deps-ghc += scientific,<<,0.4
-deps-ghc += vector,<<,0.12
-deps-ghc += hslua,<<,0.5
-deps-ghc += sha,<<,1.7
-deps-ghc += haddock-library,<<,1.5
-deps-ghc += juicypixels,<<,3.3
-deps-ghc += filemanip,<<,0.4
-deps-ghc += cmark,<<,0.6
-deps-ghc += doctemplates,<<,0.2
-deps-ghc += http-client,<<,0.6
-deps-ghc += http-client-tls,<<,0.4
-deps-ghc += http-types,<<,0.10
-deps-ghc += syb,<<,0.7
+ghc-deps += unordered-containers,<<,3
+ghc-deps += parsec3,<<,3.2
+ghc-deps += mtl,>=,2.2,<<,2.3
+ghc-deps += network,>=,2.6
+ghc-deps += network-uri,<<,2.7
+ghc-deps += text,<<,1.3
+ghc-deps += zip-archive,<<,0.4
+ghc-deps += http,<<,1:4000.4
+ghc-deps += texmath,>=,0.9,<<,0.10
+ghc-deps += xml,<<,1.4
+ghc-deps += random,<<1.2
+ghc-deps += extensible-exceptions,<<,0.2
+ghc-deps += pandoc-types,>=,1.17,<<,1.18
+ghc-deps += aeson,>=,0.7.0.5,<<,1.1
+ghc-deps += tagsoup,<<,0.15
+ghc-deps += base64-bytestring,<<,1.1
+ghc-deps += zlib,<<,0.7
+ghc-deps += highlighting-kate,>=,0.6.2,<<,0.7
+ghc-deps += data-default,<<,0.8
+ghc-deps += temporary,<<,1.3
+ghc-deps += blaze-html,<<,0.9
+ghc-deps += blaze-markup,<<,0.8
+ghc-deps += yaml,<<,0.9
+ghc-deps += scientific,<<,0.4
+ghc-deps += vector,<<,0.12
+ghc-deps += hslua,<<,0.5
+ghc-deps += sha,<<,1.7
+ghc-deps += haddock-library,<<,1.5
+ghc-deps += juicypixels,<<,3.3
+ghc-deps += filemanip,<<,0.4
+ghc-deps += cmark,<<,0.6
+ghc-deps += doctemplates,<<,0.2
+ghc-deps += http-client,<<,0.6
+ghc-deps += http-client-tls,<<,0.4
+ghc-deps += http-types,<<,0.10
+ghc-deps += syb,<<,0.7
# Haskell dependencies for testsuite from pandoc.cabal
-deps-ghc-test += diff,<<,0.3
-deps-ghc-test += test-framework,<<,0.9
-deps-ghc-test += test-framework-hunit,<<,0.4
-deps-ghc-test += test-framework-quickcheck2,<<,0.4
-deps-ghc-test += quickcheck2,<<,2.10
-deps-ghc-test += hunit,<<,1.6
-deps-ghc-test += template-haskell,<<,2.9
-deps-ghc-test += ansi-terminal,<<,0.7
+ghc-deps-test += diff,<<,0.3
+ghc-deps-test += test-framework,<<,0.9
+ghc-deps-test += test-framework-hunit,<<,0.4
+ghc-deps-test += test-framework-quickcheck2,<<,0.4
+ghc-deps-test += quickcheck2,<<,2.10
+ghc-deps-test += hunit,<<,1.6
+ghc-deps-test += template-haskell,<<,2.9
+ghc-deps-test += ansi-terminal,<<,0.7
# Haskell dependencies (maybe) needed for documentation
# TODO: actually use these (not maintain Build-depends-indep by hand)
-deps-ghc-doc += blaze-builder
-deps-ghc-doc += digest
-deps-ghc-doc += dlist
-deps-ghc-doc += hs-bibutils
-deps-ghc-doc += pcre-light
-deps-ghc-doc += rts
-deps-ghc-doc += transformers
-deps-ghc-doc += utf8-string
+ghc-deps-doc += blaze-builder
+ghc-deps-doc += digest
+ghc-deps-doc += dlist
+ghc-deps-doc += hs-bibutils
+ghc-deps-doc += pcre-light
+ghc-deps-doc += rts
+ghc-deps-doc += transformers
+ghc-deps-doc += utf8-string
# Needed by upstream build process
CDBS_BUILD_DEPENDS +=, ghc, alex, happy
-CDBS_BUILD_DEPENDS += $(call expand-ghc-deps,dev,$(deps-ghc))
+CDBS_BUILD_DEPENDS += $(call expand-ghc-deps,dev,$(ghc-deps))
# FIXME: enable, set DEB_ENABLE_TESTS = yes, and configure with -ftests
-#CDBS_BUILD_DEPENDS += $(call expand-ghc-deps,dev,$(deps-ghc-test))
+#CDBS_BUILD_DEPENDS += $(call expand-ghc-deps,dev,$(ghc-deps-test))
CDBS_BUILD_DEPENDS +=, ghc-prof
-CDBS_BUILD_DEPENDS +=, $(call strip-ghc-deps,prof,$(deps-ghc))
+CDBS_BUILD_DEPENDS +=, $(call strip-ghc-deps,prof,$(ghc-deps))
CDBS_BUILD_DEPENDS_INDEP +=, ghc-doc
-CDBS_BUILD_DEPENDS_INDEP +=, $(call strip-ghc-deps,doc,$(deps-ghc) $(deps-ghc-doc))
+CDBS_BUILD_DEPENDS_INDEP +=, $(call strip-ghc-deps,doc,$(ghc-deps) $(ghc-deps-doc))
# Needed for our packaging
# * recent haskell-devscripts needed for version-less datadir