summaryrefslogtreecommitdiff
path: root/freebsd/Makefile.in
diff options
context:
space:
mode:
authorfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-08-25 17:35:53 +0000
committerfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-08-25 17:35:53 +0000
commit64306faf7de8fc903110c4ea11aa47b4c8c79c0b (patch)
tree1739f56ddeb7eefb3ef571ed878ddb33d79d2a14 /freebsd/Makefile.in
parent631d3930af0d27fb64d6790be487e9cbddccb17d (diff)
Modifications in freebsd packaging:
+ Added freebsd target to Makefile, which creates Makefile from Makefile.in and creates distinfo. + Removed Makefile and distinfo from the repository. git-svn-id: https://pandoc.googlecode.com/svn/trunk@887 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'freebsd/Makefile.in')
-rw-r--r--freebsd/Makefile.in44
1 files changed, 44 insertions, 0 deletions
diff --git a/freebsd/Makefile.in b/freebsd/Makefile.in
new file mode 100644
index 000000000..0b0ce1821
--- /dev/null
+++ b/freebsd/Makefile.in
@@ -0,0 +1,44 @@
+# New ports collection makefile for: pandoc
+# Date created: 9 February 2007
+# Whom: John MacFarlane <jgm@berkeley.edu>
+#
+# $FreeBSD: ports/textproc/pandoc/Makefile,v 1.2 2007/05/19 20:24:07 flz Exp $
+#
+
+PORTNAME= pandoc
+PORTVERSION= @VERSION@
+CATEGORIES= textproc haskell
+MASTER_SITES= http://pandoc.googlecode.com/files/
+DISTNAME= pandoc-${PORTVERSION}
+
+MAINTAINER= jgm@berkeley.edu
+COMMENT= A general markup converter
+
+BUILD_DEPENDS= ghc>=6.6:${PORTSDIR}/lang/ghc
+
+MANCOMPRESSED= no
+MAN1= pandoc.1 markdown2pdf.1 html2markdown.1 hsmarkdown.1
+
+USE_GMAKE= yes
+USE_PERL5= yes
+
+PLIST_FILES= bin/pandoc bin/markdown2pdf bin/html2markdown bin/hsmarkdown
+PORTDOCS= BUGS README README.html
+SCRIPTS= hsmarkdown html2markdown markdown2pdf
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/dist/build/pandoc/pandoc ${PREFIX}/bin
+.for script in ${SCRIPTS}
+ @${INSTALL_SCRIPT} ${WRKSRC}/${script} ${PREFIX}/bin
+.endfor
+.for man in ${MAN1}
+ @${INSTALL_MAN} ${WRKSRC}/man/man1/${man} ${PREFIX}/man/man1
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>