summaryrefslogtreecommitdiff
path: root/freebsd
diff options
context:
space:
mode:
authorfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-02-14 17:09:17 +0000
committerfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-02-14 17:09:17 +0000
commit5a9b7c229dfa3c5b7801dff31a8d2d534b4ab170 (patch)
treebe039253c6cebd3e47d25ba5021fcc81f73db40b /freebsd
parent7f65a4e9149b1c8bbf5df42812782cbfabb0756b (diff)
Added freebsd directory, with freebsd port, to repository.
git-svn-id: https://pandoc.googlecode.com/svn/trunk@531 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'freebsd')
-rw-r--r--freebsd/Makefile44
-rw-r--r--freebsd/distinfo3
-rw-r--r--freebsd/pkg-descr19
3 files changed, 66 insertions, 0 deletions
diff --git a/freebsd/Makefile b/freebsd/Makefile
new file mode 100644
index 000000000..d2886bc87
--- /dev/null
+++ b/freebsd/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: pandoc
+# Date created: 9 February 2007
+# Whom: John MacFarlane <jgm@berkeley.edu>
+#
+# $FreeBSD: ports/textproc/pandoc/Makefile,v 1.1 2007/02/11 17:21:55 nox Exp $
+#
+
+PORTNAME= pandoc
+PORTVERSION= 0.3
+CATEGORIES= textproc haskell
+MASTER_SITES= http://pandoc.googlecode.com/files/
+DISTNAME= pandoc-${PORTVERSION}
+
+MAINTAINER= jgm@berkeley.edu
+COMMENT= A general markup converter
+
+BUILD_DEPENDS= ghc>=6.4:${PORTSDIR}/lang/ghc
+
+MANCOMPRESSED= no
+MAN1= pandoc.1 markdown2pdf.1 html2markdown.1 hsmarkdown.1
+
+USE_GMAKE= yes
+USE_PERL5= yes
+
+PLIST_FILES= bin/pandoc bin/markdown2pdf bin/html2markdown bin/hsmarkdown
+PORTDOCS= BUGS README README.html
+SCRIPTS= hsmarkdown html2markdown markdown2pdf
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/dist/build/pandoc/pandoc ${PREFIX}/bin
+.for script in ${SCRIPTS}
+ @${INSTALL_SCRIPT} ${WRKSRC}/${script} ${PREFIX}/bin
+.endfor
+.for man in ${MAN1}
+ @${INSTALL_MAN} ${WRKSRC}/man/man1/${man} ${PREFIX}/man/man1
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/freebsd/distinfo b/freebsd/distinfo
new file mode 100644
index 000000000..b059d16ce
--- /dev/null
+++ b/freebsd/distinfo
@@ -0,0 +1,3 @@
+MD5 (pandoc-0.3.tar.gz) = 08ea5da564b721bd3cd52eee316143a1
+SHA256 (pandoc-0.3.tar.gz) = b010436d325c8ec67e2f9c238474089f76c895bec3ef19ca13c82da5860a4b05
+SIZE (pandoc-0.3.tar.gz) = 243335
diff --git a/freebsd/pkg-descr b/freebsd/pkg-descr
new file mode 100644
index 000000000..6638e6cd4
--- /dev/null
+++ b/freebsd/pkg-descr
@@ -0,0 +1,19 @@
+Pandoc is a command-line tool for converting from one markup format
+to another. It can read markdown and (subsets of) reStructuredText,
+HTML, and LaTeX, and it can write markdown, reStructuredText, HTML,
+LaTeX, DocBook, RTF, and S5 HTML slide shows.
+
+Pandoc extends standard markdown syntax with footnotes, embedded LaTeX,
+and other features. A compatibility mode is provided for those who
+need a drop-in replacement for Markdown.pl. Included wrapper scripts
+make it easy to convert markdown documents to PDFs and to convert web
+pages to markdown documents.
+
+In contrast to existing tools for converting markdown to HTML, which
+use regex substitutions, pandoc has a modular design: it consists of a
+set of readers, which parse text in a given format and produce a native
+representation of the document, and a set of writers, which convert
+this native representation into a target format. Thus, adding an input
+or output format requires only adding a reader or writer.
+
+WWW: http://sophos.berkeley.edu/macfarlane/pandoc/