summaryrefslogtreecommitdiff
path: root/web/Makefile
diff options
context:
space:
mode:
authorfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-01-09 20:42:13 +0000
committerfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-01-09 20:42:13 +0000
commit8d4a1ed0395116f9503d1058c36bdbc1cd61bbc5 (patch)
treeb6c6be85acd104a1ae720dc9fc40c0914023b0be /web/Makefile
parentc80f181137df4953ae994ef096ca1aedb3a873b0 (diff)
More website changes. Include demo of docbook postprocessed
by xmlto. git-svn-id: https://pandoc.googlecode.com/svn/trunk@486 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'web/Makefile')
-rw-r--r--web/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/web/Makefile b/web/Makefile
index 644ce61db..d37568b1b 100644
--- a/web/Makefile
+++ b/web/Makefile
@@ -1,11 +1,17 @@
-all: index.html osx-notes.html README.html INSTALL.html features.html changelog.html examples.html
-
+ALL := index.html osx-notes.html README.html INSTALL.html features.html changelog.html examples.html
PANDOC_PATH ?= $(dir $(shell which pandoc))
MAKEPAGE = $(PANDOC_PATH)/pandoc -s -S -B header.html -A footer.html -H css
PANDOC_DEPS = header.html footer.html css
+all : $(ALL)
+
+.PHONY: clean
+clean:
+ for file in $(ALL); do rm $$file; done; \
+ rm -r example*;
+
examples.txt : $(PANDOC_DEPS) mkdemos.sh
- ./mkdemos.sh . $$PANDOC_PATH > $@
+ ./mkdemos.sh . $(PANDOC_PATH) > $@
%.html : %.txt $(PANDOC_DEPS)
$(MAKEPAGE) $< > $@