summaryrefslogtreecommitdiff
path: root/web/Makefile
diff options
context:
space:
mode:
authorfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-07-14 06:28:09 +0000
committerfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-07-14 06:28:09 +0000
commit9a96429a1a018803c8b1af6d9a9300d346b53b3c (patch)
tree59e242cc5fcf1b35da07ca555bb8eee5d88df268 /web/Makefile
parent532dd43139d4056bc83b7994bd68b965d07e750b (diff)
Revamped website.
git-svn-id: https://pandoc.googlecode.com/svn/trunk@699 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'web/Makefile')
-rw-r--r--web/Makefile25
1 files changed, 16 insertions, 9 deletions
diff --git a/web/Makefile b/web/Makefile
index ebe5ad7cc..708332781 100644
--- a/web/Makefile
+++ b/web/Makefile
@@ -1,8 +1,6 @@
-ALL := index.html osx-notes.html README.html INSTALL.html features.html changelog.html examples.html
+ALL := index.html osx-notes.html README.html INSTALL.html examples.html pandoc1.html markdown2pdf1.html html2markdown1.html hsmarkdown1.html
PANDOC_PATH ?= $(dir $(shell which pandoc))
-MAKEPAGE = $(PANDOC_PATH)/pandoc -s -S -B header.html -A footer.html -H css
-PANDOC_DEPS = header.html footer.html css
-
+MAKEPAGE = $(PANDOC_PATH)/pandoc -s -S -c pandoc.css -A footer.html
all : $(ALL)
.PHONY: clean
@@ -17,14 +15,23 @@ examples.txt : $(PANDOC_DEPS) mkdemos.pl config.xsl S5DEMO README demos
do highlight -u utf-8 --style emacs $$file > $$file.html; \
done
-%.html : %.txt $(PANDOC_DEPS)
- $(MAKEPAGE) $< > $@
+index.html : index.txt
+ $(MAKEPAGE) --toc $< > $@
+
+README.html : README
+ $(MAKEPAGE) --toc $< > $@
-%.html : % $(PANDOC_DEPS)
+INSTALL.html : INSTALL
+ $(MAKEPAGE) --toc $< > $@
+
+%.html : %.txt
$(MAKEPAGE) $< > $@
-changelog.html : changelog.txt $(PANDOC_DEPS)
- $(MAKEPAGE) -T "Pandoc changelog" $< > $@
+%1.html : %.1
+ groff -man -T html $< > $@
+
+%.html : %
+ $(MAKEPAGE) $< > $@
upload :
sitecopy --update macfarlane