summaryrefslogtreecommitdiff
path: root/web/Makefile
diff options
context:
space:
mode:
authorfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-01-09 18:55:50 +0000
committerfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-01-09 18:55:50 +0000
commitc80f181137df4953ae994ef096ca1aedb3a873b0 (patch)
treeb4ebd08386230ec2b4eef9f5ead3a55888f81aa7 /web/Makefile
parent55031090dea5e7b3e1f1932c12573d369caf13ef (diff)
Reorganized Makefile target - now uses a subsidiary Makefile
that can be run from the website directory for small changes. git-svn-id: https://pandoc.googlecode.com/svn/trunk@485 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'web/Makefile')
-rw-r--r--web/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/web/Makefile b/web/Makefile
new file mode 100644
index 000000000..644ce61db
--- /dev/null
+++ b/web/Makefile
@@ -0,0 +1,20 @@
+all: index.html osx-notes.html README.html INSTALL.html features.html changelog.html examples.html
+
+PANDOC_PATH ?= $(dir $(shell which pandoc))
+MAKEPAGE = $(PANDOC_PATH)/pandoc -s -S -B header.html -A footer.html -H css
+PANDOC_DEPS = header.html footer.html css
+
+examples.txt : $(PANDOC_DEPS) mkdemos.sh
+ ./mkdemos.sh . $$PANDOC_PATH > $@
+
+%.html : %.txt $(PANDOC_DEPS)
+ $(MAKEPAGE) $< > $@
+
+%.html : % $(PANDOC_DEPS)
+ $(MAKEPAGE) $< > $@
+
+changelog.html : changelog.txt $(PANDOC_DEPS)
+ $(MAKEPAGE) -T "Pandoc changelog" $< > $@
+
+upload :
+ sitecopy --update macfarlane