summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/1001_online_latexmathml_default.patch100
-rw-r--r--debian/patches/2001_avoid_missing_files.patch34
3 files changed, 62 insertions, 73 deletions
diff --git a/debian/changelog b/debian/changelog
index 11dd49b06..cbdf11b91 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -10,6 +10,7 @@ pandoc (2.1.2~dfsg-1) UNRELEASED; urgency=medium
* Team upload.
* New upstream release (Closes: #891243).
* Drop patches merged upstream.
+ * Refresh remaining patches.
* Point Vcs-* at salsa.
-- Sean Whitton <spwhitton@spwhitton.name> Tue, 24 Apr 2018 10:49:44 -0700
diff --git a/debian/patches/1001_online_latexmathml_default.patch b/debian/patches/1001_online_latexmathml_default.patch
index d19d8199e..3d104504a 100644
--- a/debian/patches/1001_online_latexmathml_default.patch
+++ b/debian/patches/1001_online_latexmathml_default.patch
@@ -1,51 +1,11 @@
Description: use online LaTeXMathML.js by default
Author: Jonas Smedegaard <dr@jones.dk>
-Last-Update: 2017-07-21
+Last-Update: 2018-04-24
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
---- a/pandoc.hs
-+++ b/pandoc.hs
-@@ -819,8 +819,11 @@
-
- , Option "m" ["latexmathml", "asciimathml"]
- (OptArg
-- (\arg opt ->
-- return opt { optHTMLMathMethod = LaTeXMathML arg })
-+ (\arg opt -> do
-+ let url' = case arg of
-+ Just u -> u
-+ Nothing -> "http://math.etsu.edu/LaTeXMathML/LaTeXMathML.js"
-+ return opt { optHTMLMathMethod = LaTeXMathML url'})
- "URL")
- "" -- "Use LaTeXMathML script in html output"
-
-@@ -1319,12 +1322,6 @@
- in throwIO e')
- else throwIO e)
-
-- variables' <- case mathMethod of
-- LaTeXMathML Nothing -> do
-- s <- readDataFileUTF8 datadir "LaTeXMathML.js"
-- return $ ("mathml-script", s) : variables
-- _ -> return variables
--
- variables'' <- if format == "dzslides"
- then do
- dztempl <- readDataFileUTF8 datadir
-@@ -1333,8 +1330,8 @@
- let dzcore = unlines
- $ dropWhile (not . (dzline `isPrefixOf`))
- $ lines dztempl
-- return $ ("dzslides-core", dzcore) : variables'
-- else return variables'
-+ return $ ("dzslides-core", dzcore) : variables
-+ else return variables
-
- let sourceURL = case sources of
- [] -> Nothing
--- a/src/Text/Pandoc/Options.hs
+++ b/src/Text/Pandoc/Options.hs
-@@ -299,7 +299,7 @@
+@@ -104,7 +104,7 @@ defaultAbbrevs = Set.fromList
data EPUBVersion = EPUB2 | EPUB3 deriving (Eq, Show, Read, Data, Typeable, Generic)
data HTMLMathMethod = PlainMath
@@ -56,9 +16,9 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
| WebTeX String -- url of TeX->image script.
--- a/src/Text/Pandoc/Writers/HTML.hs
+++ b/src/Text/Pandoc/Writers/HTML.hs
-@@ -142,7 +142,7 @@
- let notes = reverse (stNotes st)
- let thebody = blocks' >> footnoteSection opts notes
+@@ -259,7 +259,7 @@ pandocToHtml opts (Pandoc meta blocks) =
+ notes <- footnoteSection opts (reverse (stNotes st))
+ let thebody = blocks' >> notes
let math = case writerHTMLMathMethod opts of
- LaTeXMathML (Just url) ->
+ LaTeXMathML url ->
@@ -67,22 +27,50 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
$ mempty
--- a/man/pandoc.1
+++ b/man/pandoc.1
-@@ -1104,14 +1104,10 @@
- .SS Math rendering in HTML
+@@ -1302,15 +1302,16 @@ Note that this option does not imply \f[
+ .RE
.TP
.B \f[C]\-m\f[] [\f[I]URL\f[]], \f[C]\-\-latexmathml\f[][\f[C]=\f[]\f[I]URL\f[]]
--Use the LaTeXMathML script to display embedded TeX math in HTML output.
--To insert a link to a local copy of the \f[C]LaTeXMathML.js\f[] script,
--provide a \f[I]URL\f[].
--If no \f[I]URL\f[] is provided, the contents of the script will be
--inserted directly into the HTML header, preserving portability at the
--price of efficiency.
--If you plan to use math on several pages, it is much better to link to a
--copy of the script, so it can be cached.
-+Use LaTeXMathML to display embedded TeX math in HTML output.
+-\f[I]Deprecated.\f[] Use the LaTeXMathML script to display embedded TeX
++\f[I]Deprecated.\f[] Use LaTeXMathML to display embedded TeX
+ math in HTML output.
+ TeX math will be displayed between \f[C]$\f[] or \f[C]$$\f[] characters
+ and put in \f[C]<span>\f[] tags with class \f[C]LaTeX\f[].
+ The LaTeXMathML JavaScript will then change it to MathML.
+ Note that currently only Firefox and Safari (and select e\-book readers)
+ natively support MathML.
+-To insert a link the \f[C]LaTeXMathML.js\f[] script, provide a
+-\f[I]URL\f[].
+The \f[I]URL\f[] should point to the \f[C]LaTeXMathML.js\f[] load script.
+If a \f[I]URL\f[] is not provided, a link to LaTeXMathML.js at the
+Homepage of LaTeXMathML will be inserted.
.RS
.RE
.TP
+--- a/src/Text/Pandoc/App.hs
++++ b/src/Text/Pandoc/App.hs
+@@ -351,12 +351,6 @@ convertWithOpts opts = do
+ maybe return (addStringAsVariable "epub-cover-image")
+ (optEpubCoverImage opts)
+ >>=
+- (\vars -> case optHTMLMathMethod opts of
+- LaTeXMathML Nothing -> do
+- s <- UTF8.toString <$> readDataFile "LaTeXMathML.js"
+- return $ ("mathml-script", s) : vars
+- _ -> return vars)
+- >>=
+ (\vars -> if format == "dzslides"
+ then do
+ dztempl <- UTF8.toString <$> readDataFile
+@@ -1396,7 +1390,10 @@ options =
+ (OptArg
+ (\arg opt -> do
+ deprecatedOption "--latexmathml, --asciimathml, -m" ""
+- return opt { optHTMLMathMethod = LaTeXMathML arg })
++ let url' = case arg of
++ Just u -> u
++ Nothing -> "http://math.etsu.edu/LaTeXMathML/LaTeXMathML.js"
++ return opt { optHTMLMathMethod = LaTeXMathML url' })
+ "URL")
+ "" -- "Use LaTeXMathML script in html output"
+
diff --git a/debian/patches/2001_avoid_missing_files.patch b/debian/patches/2001_avoid_missing_files.patch
index 5d5adcc75..306722348 100644
--- a/debian/patches/2001_avoid_missing_files.patch
+++ b/debian/patches/2001_avoid_missing_files.patch
@@ -1,34 +1,34 @@
Description: avoid missing files during build
Author: Jonas Smedegaard <dr@jones.dk>
-Last-Update: 2017-07-21
+Last-Update: 2018-04-24
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/pandoc.cabal
+++ b/pandoc.cabal
-@@ -95,8 +95,6 @@
- data/odt/META-INF/manifest.xml
+@@ -149,8 +149,6 @@ data-files:
+ data/pptx/[Content_Types].xml
-- stylesheet for EPUB writer
data/epub.css
- -- data for LaTeXMathML writer
- data/LaTeXMathML.js
-- data for dzslides writer
data/dzslides/template.html
- -- sample lua custom writer
-@@ -141,7 +139,6 @@
- tests/mediawiki-reader.wiki
- tests/rst-reader.rst
- tests/s5-basic.html
-- tests/s5-fancy.html
- tests/s5-fragment.html
- tests/s5-inserts.html
- tests/tables.context
---- a/tests/Tests/Old.hs
-+++ b/tests/Tests/Old.hs
-@@ -92,7 +92,6 @@
+ -- default abbreviations file
+@@ -222,7 +220,6 @@ extra-source-files:
+ test/rst-reader.rst
+ test/jats-reader.xml
+ test/s5-basic.html
+- test/s5-fancy.html
+ test/s5-fragment.html
+ test/s5-inserts.html
+ test/tables.context
+--- a/test/Tests/Old.hs
++++ b/test/Tests/Old.hs
+@@ -57,7 +57,6 @@ tests = [ testGroup "markdown"
]
, testGroup "s5"
[ s5WriterTest "basic" ["-s"] "s5"
- , s5WriterTest "fancy" ["-s","-m","-i"] "s5"
- , s5WriterTest "fragment" [] "html"
+ , s5WriterTest "fragment" [] "html4"
, s5WriterTest "inserts" ["-s", "-H", "insert",
- "-B", "insert", "-A", "insert", "-c", "main.css"] "html"
+ "-B", "insert", "-A", "insert", "-c", "main.css"] "html4"