summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 46afc990d..5fc2b3d66 100644
--- a/Makefile
+++ b/Makefile
@@ -85,7 +85,15 @@ download_stats:
curl https://api.github.com/repos/jgm/pandoc/releases | \
jq -r '.[] | .assets | .[] | "\(.download_count)\t\(.name)"'
+pandoc-templates:
+ rm ../pandoc-templates/default.* ; \
+ cp data/templates/default.* ../pandoc-templates/ ; \
+ pushd ../pandoc-templates/ && \
+ git add default.* && \
+ git commit -m "Updated templates for pandoc $(version)" && \
+ popd
+
clean:
stack clean
-.PHONY: deps quick full haddock install clean test bench changes_github macospkg dist prof download_stats reformat lint weigh doc/lua-filters.md packages
+.PHONY: deps quick full haddock install clean test bench changes_github macospkg dist prof download_stats reformat lint weigh doc/lua-filters.md packages pandoc-templates