summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 0bfea6f7b..105160760 100644
--- a/Makefile
+++ b/Makefile
@@ -3,7 +3,7 @@ makemanpages=$(shell find dist -type f -name make-pandoc-man-pages)
ifeq "${makemanpages}" ""
makemanpages=@echo "You need to 'cabal configure -fmake-pandoc-man-pages && cabal build'" && exit 1
endif
-setup=$(shell find dist -type f -name setup)
+setup=dist/setup/setup
MANPAGES=man/man1/pandoc.1 man/man5/pandoc_markdown.5
CABALARGS=-fmake-pandoc-man-pages --enable-tests --enable-benchmarks
@@ -28,11 +28,10 @@ install:
haddock:
cabal haddock
-sdist: man haddock
+sdist: man
# note: cabal sdist doesn't work well with preprocessors for some cabal versions
${setup} sdist
-# sanity check on sdist
dist: sdist
rm -rf "pandoc-${version}"
tar xvzf dist/pandoc-${version}.tar.gz