summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 0d5b518b4..3183b5af0 100644
--- a/Makefile
+++ b/Makefile
@@ -5,7 +5,7 @@ ifeq "${makemanpages}" ""
endif
setup=dist/setup/setup
MANPAGES=man/man1/pandoc.1 man/man5/pandoc_markdown.5
-CABALARGS=-fmake-pandoc-man-pages --enable-tests --enable-benchmarks
+CABALARGS=-fmake-pandoc-man-pages -ftrypandoc --enable-tests --enable-benchmarks
all: build test
@@ -44,6 +44,9 @@ dist: sdist
man: ${MANPAGES}
+osxpkg:
+ ./make_osx_package.sh
+
%.1: %.1.template
${makemanpages}
@@ -53,4 +56,4 @@ man: ${MANPAGES}
clean:
-rm ${MANPAGES}
-.PHONY: all man clean test build bench haddock sdist
+.PHONY: all man clean test build bench haddock sdist osxpkg