summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000..99588c157
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,15 @@
+makemanpages=$(shell find dist -type f -name make-pandoc-man-pages | head -1)
+MANPAGES=man/man1/pandoc.1 man/man5/pandoc_markdown.5
+
+all: ${MANPAGES}
+
+%.1: %.1.template
+ ${makemanpages}
+
+%.5: %.5.template
+ ${makemanpages}
+
+clean:
+ -rm ${MANPAGES}
+
+.PHONY: all clean