summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 5584fa322..0bfea6f7b 100644
--- a/Makefile
+++ b/Makefile
@@ -1,3 +1,4 @@
+version=$(shell grep '^Version:' pandoc.cabal | awk '{print $$2;}')
makemanpages=$(shell find dist -type f -name make-pandoc-man-pages)
ifeq "${makemanpages}" ""
makemanpages=@echo "You need to 'cabal configure -fmake-pandoc-man-pages && cabal build'" && exit 1
@@ -27,10 +28,17 @@ install:
haddock:
cabal haddock
-sdist: build test man haddock
+sdist: man haddock
# note: cabal sdist doesn't work well with preprocessors for some cabal versions
${setup} sdist
+# sanity check on sdist
+dist: sdist
+ rm -rf "pandoc-${version}"
+ tar xvzf dist/pandoc-${version}.tar.gz
+ cd pandoc-${version}
+ cabal configure ${CABALARGS} && cabal build && cabal test && cd .. && rm -rf "pandoc-${version}"
+
man: ${MANPAGES}
%.1: %.1.template