summaryrefslogtreecommitdiff
path: root/pandoc.cabal
diff options
context:
space:
mode:
Diffstat (limited to 'pandoc.cabal')
-rw-r--r--pandoc.cabal715
1 files changed, 422 insertions, 293 deletions
diff --git a/pandoc.cabal b/pandoc.cabal
index e2b19dfe5..a11a1bb63 100644
--- a/pandoc.cabal
+++ b/pandoc.cabal
@@ -1,31 +1,33 @@
-Name: pandoc
-Version: 1.19.2.4
-Cabal-Version: >= 1.10
-Build-Type: Custom
-License: GPL
-License-File: COPYING.md
-Copyright: (c) 2006-2017 John MacFarlane
-Author: John MacFarlane <jgm@berkeley.edu>
-Maintainer: John MacFarlane <jgm@berkeley.edu>
-Bug-Reports: https://github.com/jgm/pandoc/issues
-Stability: alpha
-Homepage: http://pandoc.org
-Category: Text
-Tested-With: GHC == 7.8.4, GHC == 7.10.2, GHC == 8.0.1
-Synopsis: Conversion between markup formats
-Description: Pandoc is a Haskell library for converting from one markup
+name: pandoc
+version: 2.1.2
+cabal-version: >= 1.10
+build-type: Custom
+license: GPL
+license-file: COPYING.md
+copyright: (c) 2006-2018 John MacFarlane
+author: John MacFarlane <jgm@berkeley.edu>
+maintainer: John MacFarlane <jgm@berkeley.edu>
+bug-reports: https://github.com/jgm/pandoc/issues
+stability: alpha
+homepage: http://pandoc.org
+category: Text
+tested-with: GHC == 7.10.3, GHC == 8.0.2, GHC == 8.2.2
+synopsis: Conversion between markup formats
+description: Pandoc is a Haskell library for converting from one markup
format to another, and a command-line tool that uses
this library. It can read several dialects of Markdown and
- (subsets of) HTML, reStructuredText, LaTeX, DocBook,
- MediaWiki markup, TWiki markup, Haddock markup, OPML,
- Emacs Org-Mode, txt2tags, Word Docx, ODT, and Textile, and
- it can write Markdown, reStructuredText, XHTML, HTML 5,
- LaTeX, ConTeXt, DocBook, OPML, TEI, OpenDocument, ODT,
- Word docx, RTF, MediaWiki, DokuWiki, ZimWiki, Textile,
- groff man pages, plain text, Emacs Org-Mode, AsciiDoc,
- Haddock markup, EPUB (v2 and v3), FictionBook2, InDesign ICML,
- and several kinds of HTML/javascript slide shows (S5, Slidy,
- Slideous, DZSlides, reveal.js).
+ (subsets of) HTML, reStructuredText, LaTeX, DocBook, JATS,
+ MediaWiki markup, TWiki markup, TikiWiki markup, Creole 1.0,
+ Haddock markup, OPML, Emacs Org-Mode, Emacs Muse, txt2tags,
+ Vimwiki, Word Docx, ODT, and Textile, and it can write
+ Markdown, reStructuredText, XHTML, HTML 5, LaTeX, ConTeXt,
+ DocBook, JATS, OPML, TEI, OpenDocument, ODT, Word docx,
+ RTF, MediaWiki, DokuWiki, ZimWiki, Textile, groff man,
+ groff ms, plain text, Emacs Org-Mode, AsciiDoc,
+ Haddock markup, EPUB (v2 and v3), FictionBook2, InDesign
+ ICML, Muse, LaTeX beamer slides, PowerPoint, and several
+ kinds of HTML/JavaScript slide shows (S5, Slidy, Slideous,
+ DZSlides, reveal.js).
.
In contrast to most existing tools for converting Markdown
to HTML, pandoc has a modular design: it consists of a set of
@@ -34,14 +36,14 @@ Description: Pandoc is a Haskell library for converting from one markup
which convert this native representation into a target
format. Thus, adding an input or output format requires
only adding a reader or writer.
-Data-Files:
+data-files:
-- templates
- data/templates/default.html
+ data/templates/default.html4
data/templates/default.html5
- data/templates/default.docbook
+ data/templates/default.docbook4
data/templates/default.docbook5
+ data/templates/default.jats
data/templates/default.tei
- data/templates/default.beamer
data/templates/default.opendocument
data/templates/default.icml
data/templates/default.opml
@@ -49,7 +51,9 @@ Data-Files:
data/templates/default.context
data/templates/default.texinfo
data/templates/default.man
+ data/templates/default.ms
data/templates/default.markdown
+ data/templates/default.muse
data/templates/default.commonmark
data/templates/default.rst
data/templates/default.plain
@@ -66,8 +70,10 @@ Data-Files:
data/templates/default.haddock
data/templates/default.textile
data/templates/default.org
- data/templates/default.epub
+ data/templates/default.epub2
data/templates/default.epub3
+ -- translations
+ data/translations/*.yaml
-- source files for reference.docx
data/docx/[Content_Types].xml
data/docx/_rels/.rels
@@ -75,6 +81,7 @@ Data-Files:
data/docx/docProps/core.xml
data/docx/word/document.xml
data/docx/word/fontTable.xml
+ data/docx/word/comments.xml
data/docx/word/footnotes.xml
data/docx/word/numbering.xml
data/docx/word/settings.xml
@@ -93,269 +100,367 @@ Data-Files:
data/odt/Configurations2/accelerator/current.xml
data/odt/Thumbnails/thumbnail.png
data/odt/META-INF/manifest.xml
+ -- source files for reference.pptx
+ data/pptx/_rels/.rels
+ data/pptx/docProps/thumbnail.jpeg
+ data/pptx/docProps/app.xml
+ data/pptx/docProps/core.xml
+ data/pptx/ppt/slideLayouts/_rels/slideLayout1.xml.rels
+ data/pptx/ppt/slideLayouts/_rels/slideLayout2.xml.rels
+ data/pptx/ppt/slideLayouts/_rels/slideLayout3.xml.rels
+ data/pptx/ppt/slideLayouts/_rels/slideLayout4.xml.rels
+ data/pptx/ppt/slideLayouts/_rels/slideLayout5.xml.rels
+ data/pptx/ppt/slideLayouts/_rels/slideLayout6.xml.rels
+ data/pptx/ppt/slideLayouts/_rels/slideLayout7.xml.rels
+ data/pptx/ppt/slideLayouts/_rels/slideLayout8.xml.rels
+ data/pptx/ppt/slideLayouts/_rels/slideLayout9.xml.rels
+ data/pptx/ppt/slideLayouts/_rels/slideLayout10.xml.rels
+ data/pptx/ppt/slideLayouts/_rels/slideLayout11.xml.rels
+ data/pptx/ppt/slideLayouts/slideLayout1.xml
+ data/pptx/ppt/slideLayouts/slideLayout2.xml
+ data/pptx/ppt/slideLayouts/slideLayout3.xml
+ data/pptx/ppt/slideLayouts/slideLayout4.xml
+ data/pptx/ppt/slideLayouts/slideLayout5.xml
+ data/pptx/ppt/slideLayouts/slideLayout6.xml
+ data/pptx/ppt/slideLayouts/slideLayout7.xml
+ data/pptx/ppt/slideLayouts/slideLayout8.xml
+ data/pptx/ppt/slideLayouts/slideLayout9.xml
+ data/pptx/ppt/slideLayouts/slideLayout10.xml
+ data/pptx/ppt/slideLayouts/slideLayout11.xml
+ data/pptx/ppt/_rels/presentation.xml.rels
+ data/pptx/ppt/theme/theme1.xml
+ data/pptx/ppt/presProps.xml
+ data/pptx/ppt/slides/_rels/slide1.xml.rels
+ data/pptx/ppt/slides/_rels/slide2.xml.rels
+ data/pptx/ppt/slides/slide2.xml
+ data/pptx/ppt/slides/slide1.xml
+ data/pptx/ppt/viewProps.xml
+ data/pptx/ppt/tableStyles.xml
+ data/pptx/ppt/slideMasters/_rels/slideMaster1.xml.rels
+ data/pptx/ppt/slideMasters/slideMaster1.xml
+ data/pptx/ppt/presentation.xml
+ data/pptx/ppt/notesMasters/_rels/notesMaster1.xml.rels
+ data/pptx/ppt/notesMasters/notesMaster1.xml
+ data/pptx/ppt/notesSlides/_rels/notesSlide1.xml.rels
+ data/pptx/ppt/notesSlides/notesSlide1.xml
+ data/pptx/ppt/notesSlides/_rels/notesSlide2.xml.rels
+ data/pptx/ppt/notesSlides/notesSlide2.xml
+ data/pptx/ppt/theme/theme2.xml
+ data/pptx/[Content_Types].xml
-- stylesheet for EPUB writer
data/epub.css
-- data for LaTeXMathML writer
data/LaTeXMathML.js
-- data for dzslides writer
data/dzslides/template.html
+ -- default abbreviations file
+ data/abbreviations
-- sample lua custom writer
data/sample.lua
+ -- lua init script
+ data/init.lua
+ -- pandoc lua module
+ data/pandoc.lua
+ -- lua List module
+ data/pandoc.List.lua
-- bash completion template
data/bash_completion.tpl
+ -- jats csl
+ data/jats.csl
-- documentation
MANUAL.txt, COPYRIGHT
-Extra-Source-Files:
+extra-source-files:
-- documentation
- INSTALL.md, BUGS, README.md, CONTRIBUTING.md, changelog
+ INSTALL.md, AUTHORS.md, README.md,
+ CONTRIBUTING.md, BUGS, changelog,
man/pandoc.1
-- stack build plan
stack.yaml
-- files needed to build man page
- man/capitalizeHeaders.hs
- man/removeNotes.hs
- man/removeLinks.hs
+ man/manfilter.lua
man/pandoc.1.template
-- trypandoc
trypandoc/Makefile
trypandoc/index.html
-- tests
- tests/bodybg.gif
- tests/*.native
- tests/docbook-reader.docbook
- tests/docbook-xref.docbook
- tests/html-reader.html
- tests/opml-reader.opml
- tests/haddock-reader.haddock
- tests/insert
- tests/lalune.jpg
- tests/movie.jpg
- tests/media/rId25.jpg
- tests/media/rId26.jpg
- tests/media/rId27.jpg
- tests/latex-reader.latex
- tests/textile-reader.textile
- tests/markdown-reader-more.txt
- tests/markdown-citations.txt
- tests/textile-reader.textile
- tests/mediawiki-reader.wiki
- tests/rst-reader.rst
- tests/s5-basic.html
- tests/s5-fancy.html
- tests/s5-fragment.html
- tests/s5-inserts.html
- tests/tables.context
- tests/tables.docbook
- tests/tables.docbook5
- tests/tables.dokuwiki
- tests/tables.zimwiki
- tests/tables.icml
- tests/tables.html
- tests/tables.latex
- tests/tables.man
- tests/tables.plain
- tests/tables.markdown
- tests/tables.mediawiki
- tests/tables.tei
- tests/tables.textile
- tests/tables.opendocument
- tests/tables.org
- tests/tables.asciidoc
- tests/tables.haddock
- tests/tables.texinfo
- tests/tables.rst
- tests/tables.rtf
- tests/tables.txt
- tests/tables.fb2
- tests/testsuite.txt
- tests/writer.latex
- tests/writer.context
- tests/writer.docbook
- tests/writer.docbook5
- tests/writer.html
- tests/writer.man
- tests/writer.markdown
- tests/writer.plain
- tests/writer.mediawiki
- tests/writer.textile
- tests/writer.opendocument
- tests/writer.org
- tests/writer.asciidoc
- tests/writer.haddock
- tests/writer.rst
- tests/writer.icml
- tests/writer.rtf
- tests/writer.tei
- tests/writer.texinfo
- tests/writer.fb2
- tests/writer.opml
- tests/writer.dokuwiki
- tests/writer.zimwiki
- tests/writers-lang-and-dir.latex
- tests/writers-lang-and-dir.context
- tests/dokuwiki_inline_formatting.dokuwiki
- tests/lhs-test.markdown
- tests/lhs-test.markdown+lhs
- tests/lhs-test.rst
- tests/lhs-test.rst+lhs
- tests/lhs-test.latex
- tests/lhs-test.latex+lhs
- tests/lhs-test.html
- tests/lhs-test.html+lhs
- tests/lhs-test.fragment.html+lhs
- tests/pipe-tables.txt
- tests/dokuwiki_external_images.dokuwiki
- tests/dokuwiki_external_images.native
- tests/dokuwiki_multiblock_table.dokuwiki
- tests/dokuwiki_multiblock_table.native
- tests/fb2/*.markdown
- tests/fb2/*.fb2
- tests/fb2/images-embedded.html
- tests/fb2/images-embedded.fb2
- tests/fb2/test-small.png
- tests/fb2/test.jpg
- tests/docx/*.docx
- tests/docx/*.native
- tests/epub/*.epub
- tests/epub/*.native
- tests/txt2tags.t2t
- tests/twiki-reader.twiki
- tests/odt/odt/*.odt
- tests/odt/markdown/*.md
- tests/odt/native/*.native
-Source-repository head
+ test/bodybg.gif
+ test/*.native
+ test/command/*.md
+ test/command/3533-rst-csv-tables.csv
+ test/command/3880.txt
+ test/command/abbrevs
+ test/command/SVG_logo-without-xml-declaration.svg
+ test/command/SVG_logo.svg
+ test/command/corrupt.svg
+ test/command/inkscape-cube.svg
+ test/command/sub-file-chapter-1.tex
+ test/command/sub-file-chapter-2.tex
+ test/command/3510-subdoc.org
+ test/command/3510-export.latex
+ test/command/3510-src.hs
+ test/command/3971b.tex
+ test/docbook-reader.docbook
+ test/docbook-xref.docbook
+ test/html-reader.html
+ test/opml-reader.opml
+ test/haddock-reader.haddock
+ test/insert
+ test/lalune.jpg
+ test/movie.jpg
+ test/media/rId25.jpg
+ test/media/rId26.jpg
+ test/media/rId27.jpg
+ test/latex-reader.latex
+ test/textile-reader.textile
+ test/markdown-reader-more.txt
+ test/markdown-citations.txt
+ test/textile-reader.textile
+ test/mediawiki-reader.wiki
+ test/vimwiki-reader.wiki
+ test/creole-reader.txt
+ test/creole-reader.native
+ test/rst-reader.rst
+ test/jats-reader.xml
+ test/s5-basic.html
+ test/s5-fancy.html
+ test/s5-fragment.html
+ test/s5-inserts.html
+ test/tables.context
+ test/tables.docbook4
+ test/tables.docbook5
+ test/tables.jats
+ test/tables.dokuwiki
+ test/tables.zimwiki
+ test/tables.icml
+ test/tables.html4
+ test/tables.html5
+ test/tables.latex
+ test/tables.man
+ test/tables.ms
+ test/tables.plain
+ test/tables.markdown
+ test/tables.mediawiki
+ test/tables.tei
+ test/tables.textile
+ test/tables.opendocument
+ test/tables.org
+ test/tables.asciidoc
+ test/tables.haddock
+ test/tables.texinfo
+ test/tables.rst
+ test/tables.rtf
+ test/tables.txt
+ test/tables.fb2
+ test/tables.muse
+ test/tables.custom
+ test/testsuite.txt
+ test/writer.latex
+ test/writer.context
+ test/writer.docbook4
+ test/writer.docbook5
+ test/writer.jats
+ test/writer.html4
+ test/writer.html5
+ test/writer.man
+ test/writer.ms
+ test/writer.markdown
+ test/writer.plain
+ test/writer.mediawiki
+ test/writer.textile
+ test/writer.opendocument
+ test/writer.org
+ test/writer.asciidoc
+ test/writer.haddock
+ test/writer.rst
+ test/writer.icml
+ test/writer.rtf
+ test/writer.tei
+ test/writer.texinfo
+ test/writer.fb2
+ test/writer.opml
+ test/writer.dokuwiki
+ test/writer.zimwiki
+ test/writer.muse
+ test/writer.custom
+ test/writers-lang-and-dir.latex
+ test/writers-lang-and-dir.context
+ test/dokuwiki_inline_formatting.dokuwiki
+ test/lhs-test.markdown
+ test/lhs-test.markdown+lhs
+ test/lhs-test.rst
+ test/lhs-test.rst+lhs
+ test/lhs-test.latex
+ test/lhs-test.latex+lhs
+ test/lhs-test.html
+ test/lhs-test.html+lhs
+ test/lhs-test.fragment.html+lhs
+ test/pipe-tables.txt
+ test/dokuwiki_external_images.dokuwiki
+ test/dokuwiki_external_images.native
+ test/dokuwiki_multiblock_table.dokuwiki
+ test/dokuwiki_multiblock_table.native
+ test/fb2/*.markdown
+ test/fb2/*.fb2
+ test/fb2/images-embedded.html
+ test/fb2/images-embedded.fb2
+ test/fb2/test-small.png
+ test/fb2/test.jpg
+ test/docx/*.docx
+ test/docx/golden/*.docx
+ test/docx/*.native
+ test/epub/*.epub
+ test/epub/*.native
+ test/pptx/*.pptx
+ test/pptx/*.native
+ test/txt2tags.t2t
+ test/twiki-reader.twiki
+ test/tikiwiki-reader.tikiwiki
+ test/odt/odt/*.odt
+ test/odt/markdown/*.md
+ test/odt/native/*.native
+ test/lua/*.lua
+source-repository head
type: git
location: git://github.com/jgm/pandoc.git
-Flag embed_data_files
+flag static
+ Description: Use static linking for pandoc executable.
+ Default: False
+
+flag embed_data_files
Description: Embed data files in binary for relocatable executable.
Default: False
-Flag trypandoc
+flag trypandoc
Description: Build trypandoc cgi executable.
Default: False
-Flag weigh-pandoc
+flag weigh-pandoc
Description: Build weigh-pandoc to measure memory usage.
Default: False
-Flag https
- Description: Enable support for downloading of resources over https.
- Default: True
-
-Flag network-uri
+flag network-uri
Description: Get Network.URI from the network-uri package
Default: True
-Flag old-locale
+flag old-locale
Description: Use old-locale and time < 1.5
Default: False
custom-setup
- setup-depends: base,
- Cabal
+ setup-depends: base, Cabal
-Library
- Build-Depends: base >= 4.7 && <5,
+library
+ build-depends: base >= 4.7 && < 5,
syb >= 0.1 && < 0.8,
- containers >= 0.1 && < 0.6,
+ containers >= 0.4.2.1 && < 0.6,
unordered-containers >= 0.2 && < 0.3,
- array >= 0.3 && < 0.6,
parsec >= 3.1 && < 3.2,
mtl >= 2.2 && < 2.3,
+ exceptions >= 0.8 && < 0.10,
filepath >= 1.1 && < 1.5,
- process >= 1 && < 1.7,
+ process >= 1.2.3 && < 1.7,
directory >= 1 && < 1.4,
bytestring >= 0.9 && < 0.11,
text >= 0.11 && < 1.3,
+ safe >= 0.3 && < 0.4,
zip-archive >= 0.2.3.4 && < 0.4,
HTTP >= 4000.0.5 && < 4000.4,
- texmath >= 0.9 && < 0.10,
+ texmath >= 0.10 && < 0.11,
xml >= 1.3.12 && < 1.4,
+ split >= 0.2 && < 0.3,
random >= 1 && < 1.2,
- extensible-exceptions >= 0.1 && < 0.2,
- pandoc-types >= 1.17 && < 1.17.1,
+ pandoc-types >= 1.17.3 && < 1.18,
aeson >= 0.7 && < 1.3,
- tagsoup >= 0.13.7 && < 0.15,
+ aeson-pretty >= 0.8.5 && < 0.9,
+ tagsoup >= 0.14.6 && < 0.15,
base64-bytestring >= 0.1 && < 1.1,
zlib >= 0.5 && < 0.7,
- skylighting >= 0.1.1.4 && < 0.2,
+ skylighting >= 0.5.1 && < 0.7,
data-default >= 0.4 && < 0.8,
temporary >= 1.1 && < 1.3,
- blaze-html >= 0.5 && < 0.10,
- blaze-markup >= 0.5.1 && < 0.9,
+ blaze-html >= 0.9 && < 0.10,
+ blaze-markup >= 0.8 && < 0.9,
yaml >= 0.8.8.2 && < 0.9,
scientific >= 0.2 && < 0.4,
vector >= 0.10 && < 0.13,
- hslua >= 0.3 && < 0.5,
+ hslua >= 0.9.5 && < 0.9.6,
+ hslua-module-text >= 0.1.2 && < 0.2,
binary >= 0.5 && < 0.10,
SHA >= 1.6 && < 1.7,
haddock-library >= 1.1 && < 1.5,
- old-time,
deepseq >= 1.3 && < 1.5,
JuicyPixels >= 3.1.6.1 && < 3.3,
- filemanip >= 0.3 && < 0.4,
- cmark >= 0.5 && < 0.6,
- doctemplates >= 0.1 && < 0.2,
- ghc-prim >= 0.2
+ Glob >= 0.7 && < 0.10,
+ cmark-gfm >= 0.1.1 && < 0.2,
+ doctemplates >= 0.2.1 && < 0.3,
+ http-client >= 0.4.30 && < 0.6,
+ http-client-tls >= 0.2.4 && < 0.4,
+ http-types >= 0.8 && < 0.12,
+ case-insensitive >= 1.2 && < 1.3
+ if os(windows)
+ cpp-options: -D_WINDOWS
+ else
+ build-depends: unix >= 2.4 && < 2.8
if flag(old-locale)
- Build-Depends: old-locale >= 1 && < 1.1,
+ build-depends: old-locale >= 1 && < 1.1,
time >= 1.2 && < 1.5
else
- Build-Depends: time >= 1.5 && < 1.9
+ build-depends: time >= 1.5 && < 1.9
if flag(network-uri)
- Build-Depends: network-uri >= 2.6 && < 2.7, network >= 2.6
+ build-depends: network-uri >= 2.6 && < 2.7, network >= 2.6
else
- Build-Depends: network >= 2 && < 2.6
- if flag(https)
- Build-Depends: http-client >= 0.4.30 && < 0.6,
- http-client-tls >= 0.2.4 && < 0.4,
- http-types >= 0.8 && < 0.10
- cpp-options: -DHTTP_CLIENT
+ build-depends: network >= 2 && < 2.6
if flag(embed_data_files)
cpp-options: -DEMBED_DATA_FILES
- Build-Tools: hsb2hs >= 0.3.1
+ build-depends: file-embed >= 0.0 && < 0.1
other-modules: Text.Pandoc.Data
if os(windows)
- Cpp-options: -D_WINDOWS
- Ghc-Options: -Wall -fno-warn-unused-do-bind
- Ghc-Prof-Options: -fprof-auto-exported
- Default-Language: Haskell98
- Other-Extensions: PatternGuards, OverloadedStrings,
+ cpp-options: -D_WINDOWS
+ ghc-options: -Wall -fno-warn-unused-do-bind
+ default-language: Haskell98
+ other-extensions: PatternGuards, OverloadedStrings,
ScopedTypeVariables, GeneralizedNewtypeDeriving,
RelaxedPolyRec, DeriveDataTypeable, TypeSynonymInstances,
FlexibleInstances
- Hs-Source-Dirs: src
- if impl(ghc < 7.10)
- Hs-Source-Dirs: prelude
- Other-Modules: Prelude
+ hs-source-dirs: src
- Exposed-Modules: Text.Pandoc,
+ exposed-modules: Text.Pandoc,
+ Text.Pandoc.App,
Text.Pandoc.Options,
+ Text.Pandoc.Extensions,
Text.Pandoc.Pretty,
Text.Pandoc.Shared,
Text.Pandoc.MediaBag,
Text.Pandoc.Error,
+ Text.Pandoc.Readers,
Text.Pandoc.Readers.HTML,
Text.Pandoc.Readers.LaTeX,
+ Text.Pandoc.Readers.LaTeX.Types,
Text.Pandoc.Readers.Markdown,
Text.Pandoc.Readers.CommonMark,
+ Text.Pandoc.Readers.Creole,
Text.Pandoc.Readers.MediaWiki,
+ Text.Pandoc.Readers.Vimwiki,
Text.Pandoc.Readers.RST,
Text.Pandoc.Readers.Org,
Text.Pandoc.Readers.DocBook,
+ Text.Pandoc.Readers.JATS,
Text.Pandoc.Readers.OPML,
- Text.Pandoc.Readers.TeXMath,
Text.Pandoc.Readers.Textile,
Text.Pandoc.Readers.Native,
Text.Pandoc.Readers.Haddock,
Text.Pandoc.Readers.TWiki,
+ Text.Pandoc.Readers.TikiWiki,
Text.Pandoc.Readers.Txt2Tags,
Text.Pandoc.Readers.Docx,
Text.Pandoc.Readers.Odt,
Text.Pandoc.Readers.EPUB,
+ Text.Pandoc.Readers.Muse,
+ Text.Pandoc.Writers,
Text.Pandoc.Writers.Native,
Text.Pandoc.Writers.Docbook,
+ Text.Pandoc.Writers.JATS,
Text.Pandoc.Writers.OPML,
Text.Pandoc.Writers.HTML,
Text.Pandoc.Writers.ICML,
@@ -364,6 +469,7 @@ Library
Text.Pandoc.Writers.OpenDocument,
Text.Pandoc.Writers.Texinfo,
Text.Pandoc.Writers.Man,
+ Text.Pandoc.Writers.Ms,
Text.Pandoc.Writers.Markdown,
Text.Pandoc.Writers.CommonMark,
Text.Pandoc.Writers.Haddock,
@@ -378,21 +484,40 @@ Library
Text.Pandoc.Writers.RTF,
Text.Pandoc.Writers.ODT,
Text.Pandoc.Writers.Docx,
+ Text.Pandoc.Writers.Powerpoint,
Text.Pandoc.Writers.EPUB,
Text.Pandoc.Writers.FB2,
Text.Pandoc.Writers.TEI,
+ Text.Pandoc.Writers.Muse,
+ Text.Pandoc.Writers.Math,
+ Text.Pandoc.Writers.Shared,
+ Text.Pandoc.Writers.OOXML,
+ Text.Pandoc.Lua,
Text.Pandoc.PDF,
Text.Pandoc.UTF8,
Text.Pandoc.Templates,
Text.Pandoc.XML,
Text.Pandoc.SelfContained,
+ Text.Pandoc.Highlighting,
+ Text.Pandoc.Logging,
Text.Pandoc.Process,
- Text.Pandoc.CSS
- Other-Modules: Text.Pandoc.Readers.Docx.Lists,
+ Text.Pandoc.MIME,
+ Text.Pandoc.Parsing,
+ Text.Pandoc.Asciify,
+ Text.Pandoc.Emoji,
+ Text.Pandoc.ImageSize,
+ Text.Pandoc.BCP47,
+ Text.Pandoc.Class
+ other-modules: Text.Pandoc.Filter,
+ Text.Pandoc.Filter.JSON,
+ Text.Pandoc.Filter.Lua,
+ Text.Pandoc.Filter.Path,
+ Text.Pandoc.Readers.Docx.Lists,
Text.Pandoc.Readers.Docx.Combine,
Text.Pandoc.Readers.Docx.Parse,
Text.Pandoc.Readers.Docx.Util,
Text.Pandoc.Readers.Docx.StyleMap,
+ Text.Pandoc.Readers.Docx.Fields,
Text.Pandoc.Readers.Odt.Base,
Text.Pandoc.Readers.Odt.Namespaces,
Text.Pandoc.Readers.Odt.StyleReader,
@@ -406,160 +531,164 @@ Library
Text.Pandoc.Readers.Odt.Arrows.Utils,
Text.Pandoc.Readers.Org.BlockStarts,
Text.Pandoc.Readers.Org.Blocks,
+ Text.Pandoc.Readers.Org.DocumentTree,
Text.Pandoc.Readers.Org.ExportSettings,
Text.Pandoc.Readers.Org.Inlines,
Text.Pandoc.Readers.Org.Meta,
Text.Pandoc.Readers.Org.ParserState,
Text.Pandoc.Readers.Org.Parsing,
Text.Pandoc.Readers.Org.Shared,
- Text.Pandoc.Writers.Shared,
- Text.Pandoc.Asciify,
- Text.Pandoc.MIME,
- Text.Pandoc.Emoji,
- Text.Pandoc.Parsing,
+ Text.Pandoc.Writers.Powerpoint.Presentation,
+ Text.Pandoc.Writers.Powerpoint.Output,
+ Text.Pandoc.Lua.Filter,
+ Text.Pandoc.Lua.Init,
+ Text.Pandoc.Lua.Module.MediaBag,
+ Text.Pandoc.Lua.Module.Pandoc,
+ Text.Pandoc.Lua.Module.Utils,
+ Text.Pandoc.Lua.Packages,
+ Text.Pandoc.Lua.StackInstances,
+ Text.Pandoc.Lua.Util,
+ Text.Pandoc.CSS,
+ Text.Pandoc.CSV,
Text.Pandoc.UUID,
- Text.Pandoc.ImageSize,
+ Text.Pandoc.Translations,
Text.Pandoc.Slides,
- Text.Pandoc.Highlighting,
Text.Pandoc.Compat.Time,
Paths_pandoc
- Buildable: True
-
-Executable pandoc
- Build-Depends: pandoc,
- pandoc-types >= 1.17 && < 1.18,
- base >= 4.2 && <5,
- directory >= 1.2 && < 1.4,
- filepath >= 1.1 && < 1.5,
- text >= 0.11 && < 1.3,
- bytestring >= 0.9 && < 0.11,
- extensible-exceptions >= 0.1 && < 0.2,
- skylighting >= 0.1.1.5 && < 0.2,
- aeson >= 0.7.0.5 && < 1.2,
- yaml >= 0.8.8.2 && < 0.9,
- containers >= 0.1 && < 0.6,
- skylighting >= 0.1.1.4 && < 0.2,
- texmath >= 0.9 && < 0.10,
- HTTP >= 4000.0.5 && < 4000.4
- if flag(network-uri)
- Build-Depends: network-uri >= 2.6 && < 2.7, network >= 2.6
- else
- Build-Depends: network >= 2 && < 2.6
- Ghc-Options: -rtsopts -with-rtsopts=-K16m -Wall -fno-warn-unused-do-bind
- Ghc-Prof-Options: -fprof-auto-exported -rtsopts -with-rtsopts=-K16m
- if os(windows)
- Cpp-options: -D_WINDOWS
- else
- Build-Depends: unix >= 2.4 && < 2.8
+ buildable: True
- Default-Language: Haskell98
- Other-Extensions: PatternGuards, OverloadedStrings,
+executable pandoc
+ build-depends: pandoc, base >= 4.7 && < 5
+ ghc-options: -rtsopts -with-rtsopts=-K16m -Wall -fno-warn-unused-do-bind -threaded
+ if flag(static)
+ ld-options: -static
+ default-language: Haskell98
+ other-extensions: PatternGuards, OverloadedStrings,
ScopedTypeVariables, GeneralizedNewtypeDeriving,
RelaxedPolyRec, DeriveDataTypeable, TypeSynonymInstances,
FlexibleInstances
- Hs-Source-Dirs: .
- if impl(ghc < 7.10)
- Hs-Source-Dirs: prelude
- Other-Modules: Prelude
- Main-Is: pandoc.hs
- Buildable: True
- Other-Modules: Paths_pandoc
+ hs-source-dirs: .
+ main-is: pandoc.hs
+ buildable: True
+ other-modules: Paths_pandoc
-Executable trypandoc
- Main-Is: trypandoc.hs
- Hs-Source-Dirs: trypandoc
- if impl(ghc < 7.10)
- Hs-Source-Dirs: prelude
- Other-Modules: Prelude
+executable trypandoc
+ main-is: trypandoc.hs
+ hs-source-dirs: trypandoc
default-language: Haskell2010
if flag(trypandoc)
- Build-Depends: base, aeson, pandoc,
+ build-depends: base, aeson, pandoc,
text, wai-extra, wai >= 0.3, http-types
- Buildable: True
+ buildable: True
else
- Buildable: False
+ buildable: False
-Executable weigh-pandoc
- Main-Is: weigh-pandoc.hs
- Hs-Source-Dirs: benchmark
- if impl(ghc < 7.10)
- Hs-Source-Dirs: prelude
- Other-Modules: Prelude
+executable weigh-pandoc
+ main-is: weigh-pandoc.hs
+ hs-source-dirs: benchmark
if flag(weigh-pandoc)
- Build-Depends: pandoc,
+ build-depends: pandoc,
base >= 4.2 && < 5,
- weigh >= 0.0 && < 0.1
- Buildable: True
+ text,
+ weigh >= 0.0 && < 0.1,
+ mtl >= 2.2 && < 2.3
+ buildable: True
else
- Buildable: False
- Ghc-Options: -rtsopts -Wall -fno-warn-unused-do-bind
- Default-Language: Haskell98
+ buildable: False
+ ghc-options: -rtsopts -Wall -fno-warn-unused-do-bind
+ default-language: Haskell98
-Test-Suite test-pandoc
- Type: exitcode-stdio-1.0
- Main-Is: test-pandoc.hs
- Hs-Source-Dirs: tests
- if impl(ghc < 7.10)
- Hs-Source-Dirs: prelude
- Other-Modules: Prelude
- Build-Depends: base >= 4.2 && < 5,
- syb >= 0.1 && < 0.8,
+test-suite test-pandoc
+ type: exitcode-stdio-1.0
+ main-is: test-pandoc.hs
+ hs-source-dirs: test
+ build-depends: base >= 4.2 && < 5,
pandoc,
- pandoc-types >= 1.17 && < 1.18,
+ pandoc-types >= 1.17.3 && < 1.18,
bytestring >= 0.9 && < 0.11,
+ base64-bytestring >= 0.1 && < 1.1,
text >= 0.11 && < 1.3,
+ time >= 1.5 && < 1.9,
directory >= 1 && < 1.4,
filepath >= 1.1 && < 1.5,
- process >= 1 && < 1.7,
- skylighting >= 0.1.1.3 && < 0.2,
+ hslua >= 0.9.5 && < 0.9.6,
+ process >= 1.2.3 && < 1.7,
+ temporary >= 1.1 && < 1.3,
Diff >= 0.2 && < 0.4,
- test-framework >= 0.3 && < 0.9,
- test-framework-hunit >= 0.2 && < 0.4,
- test-framework-quickcheck2 >= 0.2.9 && < 0.4,
- QuickCheck >= 2.4 && < 2.11,
- HUnit >= 1.2 && < 1.7,
- containers >= 0.1 && < 0.6,
- ansi-terminal >= 0.5 && < 0.8,
- executable-path >= 0.0 && < 0.4,
- zip-archive >= 0.2.3.4 && < 0.4
- Other-Modules: Tests.Old
+ tasty >= 0.11 && < 1.1,
+ tasty-hunit >= 0.9 && < 0.11,
+ tasty-quickcheck >= 0.8 && < 0.10,
+ tasty-golden >= 2.3 && < 2.4,
+ QuickCheck >= 2.4 && < 2.12,
+ containers >= 0.4.2.1 && < 0.6,
+ executable-path >= 0.0 && < 0.1,
+ zip-archive >= 0.2.3.4 && < 0.4,
+ xml >= 1.3.12 && < 1.4,
+ Glob >= 0.7 && < 0.10
+ if flag(old-locale)
+ build-depends: old-locale >= 1 && < 1.1,
+ time >= 1.2 && < 1.5
+ else
+ build-depends: time >= 1.5 && < 1.9
+ other-modules: Tests.Old
+ Tests.Command
Tests.Helpers
+ Tests.Lua
Tests.Shared
- Tests.Walk
Tests.Readers.LaTeX
Tests.Readers.HTML
+ Tests.Readers.JATS
Tests.Readers.Markdown
Tests.Readers.Org
+ Tests.Readers.Org.Block
+ Tests.Readers.Org.Block.CodeBlock
+ Tests.Readers.Org.Block.Figure
+ Tests.Readers.Org.Block.Header
+ Tests.Readers.Org.Block.List
+ Tests.Readers.Org.Block.Table
+ Tests.Readers.Org.Directive
+ Tests.Readers.Org.Inline
+ Tests.Readers.Org.Inline.Citation
+ Tests.Readers.Org.Inline.Note
+ Tests.Readers.Org.Inline.Smart
+ Tests.Readers.Org.Meta
+ Tests.Readers.Org.Shared
Tests.Readers.RST
Tests.Readers.Docx
Tests.Readers.Odt
Tests.Readers.Txt2Tags
Tests.Readers.EPUB
+ Tests.Readers.Muse
+ Tests.Readers.Creole
Tests.Writers.Native
Tests.Writers.ConTeXt
Tests.Writers.Docbook
Tests.Writers.HTML
+ Tests.Writers.JATS
Tests.Writers.Markdown
+ Tests.Writers.Org
Tests.Writers.Plain
Tests.Writers.AsciiDoc
Tests.Writers.LaTeX
Tests.Writers.Docx
Tests.Writers.RST
Tests.Writers.TEI
- Ghc-Options: -rtsopts -Wall -fno-warn-unused-do-bind -threaded
- Default-Language: Haskell98
+ Tests.Writers.Muse
+ Tests.Writers.FB2
+ Tests.Writers.Powerpoint
+ Tests.Writers.OOXML
+ ghc-options: -rtsopts -Wall -fno-warn-unused-do-bind -threaded
+ default-language: Haskell98
benchmark benchmark-pandoc
- Type: exitcode-stdio-1.0
- Main-Is: benchmark-pandoc.hs
- Hs-Source-Dirs: benchmark
- if impl(ghc < 7.10)
- Hs-Source-Dirs: prelude
- Other-Modules: Prelude
- Build-Depends: pandoc,
+ type: exitcode-stdio-1.0
+ main-is: benchmark-pandoc.hs
+ hs-source-dirs: benchmark
+ build-depends: pandoc,
+ time, bytestring, containers,
base >= 4.2 && < 5,
- syb >= 0.1 && < 0.8,
- criterion >= 1.0 && < 1.3
- Ghc-Options: -rtsopts -Wall -fno-warn-unused-do-bind
- Default-Language: Haskell98
+ text >= 0.11 && < 1.3,
+ criterion >= 1.0 && < 1.4
+ ghc-options: -rtsopts -Wall -fno-warn-unused-do-bind
+ default-language: Haskell98