summaryrefslogtreecommitdiff
path: root/INSTALL
Commit message (Collapse)AuthorAge
* Renamed Pandoc.cabal -> pandoc.cabal, for better compatibilityfiddlosopher2007-07-07
| | | | | | | | | with HackageDB, which likes the cabal file to have the same name as the tarball. Modified references to Pandoc.cabal in INSTALL and Makefile. git-svn-id: https://pandoc.googlecode.com/svn/trunk@631 788f1e2b-df1e-0410-8736-df70ead52e1b
* Changed documentation to indicate that GHC 6.6 is required.fiddlosopher2007-06-17
| | | | | | | We will no longer support GHC 6.4. git-svn-id: https://pandoc.googlecode.com/svn/trunk@603 788f1e2b-df1e-0410-8736-df70ead52e1b
* Modified HTML writer to use the Text.XHtml library. This resultsfiddlosopher2007-02-26
| | | | | | | | | | | | | | | | in cleaner, faster code, and it makes it easier to use Pandoc in other projects, like wikis, that use Text.XHtml. Two functions are now provided, writeHtml and writeHtmlString: the former outputs an Html structure, the latter a rendered string. The S5 writer is also changed, in parallel ways (writeS5, writeS5String). The Html header is now written programmatically, so it has been removed from the 'headers' directory. The S5 header is still needed, but the doctype and some of the meta declarations have been removed, since they are written programatically. The INSTALL file and cabalize have been updated to reflect the new dependency on the xhtml package. git-svn-id: https://pandoc.googlecode.com/svn/trunk@549 788f1e2b-df1e-0410-8736-df70ead52e1b
* Fix the wrapper usage instruction in INSTALL.roktas2007-01-05
| | | | git-svn-id: https://pandoc.googlecode.com/svn/trunk@421 788f1e2b-df1e-0410-8736-df70ead52e1b
* Added some instructions to INSTALL about setting the PATHfiddlosopher2007-01-04
| | | | | | | | for trying out pandoc and the shell scripts from the build directory. git-svn-id: https://pandoc.googlecode.com/svn/trunk@412 788f1e2b-df1e-0410-8736-df70ead52e1b
* Documented makefile targets in INSTALL.fiddlosopher2006-12-31
| | | | git-svn-id: https://pandoc.googlecode.com/svn/trunk@359 788f1e2b-df1e-0410-8736-df70ead52e1b
* Modified INSTALL instructions to emphasize that GNU make is required,fiddlosopher2006-11-19
| | | | | | | and that it goes by the name 'gmake' on some systems. git-svn-id: https://pandoc.googlecode.com/svn/trunk@114 788f1e2b-df1e-0410-8736-df70ead52e1b
* Modified INSTALL instructions; require "make build-all" beforefiddlosopher2006-11-07
| | | | | | | "make install-all". git-svn-id: https://pandoc.googlecode.com/svn/trunk@76 788f1e2b-df1e-0410-8736-df70ead52e1b
* * Extracted installation instructions from README into a separate file,fiddlosopher2006-10-29
INSTALL. Reason: Only those who install from source will need the information in INSTALL, so it does not need to be included in user documentation. Indeed, it might confuse people who install Pandoc by some other method. * Minor changes in README (using "Pandoc" as a generic name for the system, "'pandoc'" as a name for the executable). git-svn-id: https://pandoc.googlecode.com/svn/trunk@36 788f1e2b-df1e-0410-8736-df70ead52e1b