summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2024-01-17 17:46:23 +0000
committerSimon McVittie <smcv@debian.org>2024-01-17 23:39:39 +0000
commit6f9d40b8aa080adcaf5e5e951ea97a6d1350e5b1 (patch)
treef6803a46fe319e3358f9e60b65c0888d0e613210
parent6840efcf0127614ffcb71503458bee422ac5acc2 (diff)
d/rules: Use cross g-ir-scanner if cross-compiling (see #1060838)
-rwxr-xr-xdebian/rules7
1 files changed, 6 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 5b59ea46..b34c123a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,6 +4,7 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export DEB_LDFLAGS_MAINT_APPEND = -Wl,-O1 -Wl,-z,defs
built_binaries := $(shell dh_listpackages)
+configure_options :=
ifneq ($(filter libpango1.0-doc,$(built_binaries)),)
with_docs = true
@@ -11,6 +12,10 @@ else
with_docs = false
endif
+ifneq ($(DEB_BUILD_ARCH),$(DEB_HOST_ARCH))
+configure_options += --cross-file=$(DEB_HOST_GNU_TYPE)-gobject-introspection.ini
+endif
+
%:
dh $@
@@ -22,7 +27,7 @@ override_dh_auto_configure:
-Dauto_features=enabled \
-Dgtk_doc=$(with_docs) \
-Dinstall-tests=true \
- $(NULL)
+ $(configure_options)
override_dh_auto_test-arch:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))