summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMatthew Vernon <matthew@debian.org>2015-03-07 19:22:42 +0000
committerMatthew Vernon <matthew@debian.org>2015-03-07 19:22:42 +0000
commit14327f3f687cf722e148c589e7ae217bfe3e5079 (patch)
tree500902abaf1d37f6eb6d0c3d267af5a95d14bfb3 /debian
parentdd986e8b547c0dde924c4b566ad0894ad4f1beb9 (diff)
Patches from Mattia Rizzolo <mattia@mapreri.org> to build pcre{16,32}
These are patches from Mattia Rizzolo to build libpcre16 and libpcre32 packages. Signed-off-by: Matthew Vernon <matthew@debian.org>
Diffstat (limited to 'debian')
-rw-r--r--debian/control26
-rw-r--r--debian/libpcre16-3.install1
-rw-r--r--debian/libpcre32-3.install1
-rwxr-xr-xdebian/rules3
4 files changed, 30 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index d9f8c7d..ba8de70 100644
--- a/debian/control
+++ b/debian/control
@@ -59,7 +59,7 @@ Package: libpcre3-dev
Section: libdevel
Architecture: any
Multi-Arch: same
-Depends: libc6-dev, libpcre3 (= ${binary:Version}), libpcrecpp0 (= ${binary:Version}), ${misc:Depends}
+Depends: libc6-dev, libpcre3 (= ${binary:Version}), libpcre16-3 (= ${binary:Version}), libpcre32-3 (= ${binary:Version}), libpcrecpp0 (= ${binary:Version}), ${misc:Depends}
Conflicts: libpcre1-dev, libpcre2-dev
Description: Perl 5 Compatible Regular Expression Library - development files
This is a library of functions to support regular expressions whose syntax
@@ -92,3 +92,27 @@ Description: grep utility that uses perl 5 compatible regexes.
.
The other reason for the existence of pcregrep is that its source code is an
example of programming with libpcre.
+
+Package: libpcre16-3
+Section: libs
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Multi-Arch: same
+Pre-Depends: ${misc:Pre-Depends}
+Description: Perl 5 Compatible Regular Expression Library - 16 bit runtime files
+ This is a library of functions to support regular expressions whose syntax
+ and semantics are as close as possible to those of the Perl 5 language.
+ .
+ This package contains the 16 bit runtime library.
+
+Package: libpcre32-3
+Section: libs
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Multi-Arch: same
+Pre-Depends: ${misc:Pre-Depends}
+Description: Perl 5 Compatible Regular Expression Library - 32 bit runtime files
+ This is a library of functions to support regular expressions whose syntax
+ and semantics are as close as possible to those of the Perl 5 language.
+ .
+ This package contains the 32 bit runtime library.
diff --git a/debian/libpcre16-3.install b/debian/libpcre16-3.install
new file mode 100644
index 0000000..df85ecf
--- /dev/null
+++ b/debian/libpcre16-3.install
@@ -0,0 +1 @@
+debian/tmp/usr/lib/*/libpcre16.so.*
diff --git a/debian/libpcre32-3.install b/debian/libpcre32-3.install
new file mode 100644
index 0000000..f91755e
--- /dev/null
+++ b/debian/libpcre32-3.install
@@ -0,0 +1 @@
+debian/tmp/usr/lib/*/libpcre32.so.*
diff --git a/debian/rules b/debian/rules
index 12d98bc..9cd4df8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -32,6 +32,8 @@ configure-stamp:
--libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH) \
--enable-utf8 --enable-unicode-properties \
--disable-silent-rules \
+ --enable-pcre16 \
+ --enable-pcre32 \
$(shell . debian/jit-test) \
$(shell DEB_CFLAGS_MAINT_APPEND=-Wall DEB_BUILD_MAINT_OPTIONS=hardening=+all dpkg-buildflags --export=configure)
touch configure-stamp
@@ -112,6 +114,7 @@ binary-arch: build install
dh_fixperms -a
dh_makeshlibs -plibpcre3 --add-udeb="libpcre3-udeb" -V 'libpcre3 (>= 1:8.35)'
dh_makeshlibs -plibpcrecpp0 -V 'libpcrecpp0 (>= 7.7)'
+ dh_makeshlibs -plibpcre16-3 -plibpcre32-3
dh_installdeb -a
# dh_perl -a
dh_shlibdeps -a -ldebian/libpcre3/usr/lib/$(DEB_HOST_MULTIARCH)