summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMatthew Vernon <matthew@debian.org>2017-12-04 05:26:39 +0000
committerMatthew Vernon <matthew@debian.org>2017-12-04 05:26:39 +0000
commit6b73f9b4137716429eaae6b852c18eeec5e89837 (patch)
treeec7e626b4f04d9df08b89f35cfacb8aebbb6eaba /debian
parentd69d22f98dea37c5dd8799a281f6aaf7b8b97a46 (diff)
Correctly increase stack limit
We want the increased stack size to apply to the make check step (running it by itself doesn't achieve anything); also ignore a permission error (which we get on freebsd) - if the tests succeed it doesn't matter.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules5
1 files changed, 3 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 3b705e1..aa65429 100755
--- a/debian/rules
+++ b/debian/rules
@@ -53,8 +53,9 @@ build-stamp: configure-stamp
# Add here commands to compile the package.
$(MAKE) $(NJOBS)
ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
- ulimit -s unlimited
- $(MAKE) check VERBOSE=1
+ #ulimit returns EPERM on the freebsd buildds, but that's OK
+ #as stack limit increase only really necessary on s390
+ ulimit -s unlimited || true ; $(MAKE) check VERBOSE=1
endif
touch build-stamp