summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xdebian/rules5
1 files changed, 3 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 3b705e1..aa65429 100755
--- a/debian/rules
+++ b/debian/rules
@@ -53,8 +53,9 @@ build-stamp: configure-stamp
# Add here commands to compile the package.
$(MAKE) $(NJOBS)
ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
- ulimit -s unlimited
- $(MAKE) check VERBOSE=1
+ #ulimit returns EPERM on the freebsd buildds, but that's OK
+ #as stack limit increase only really necessary on s390
+ ulimit -s unlimited || true ; $(MAKE) check VERBOSE=1
endif
touch build-stamp